Excluding SPLFDTA (spool files) from backups

  • 18 April 2022
  • 2 replies

Badge +1



I’m aware that there is a Restore Spooled file data (SPLFDTA) check box option when Performing an IBM i File System Agent Restore.


However, what I’m looking for, is for a way to not backup the spool files to begin with. In native IBM i backup commands, the Spooled file data (SPLFDTA) option is set to *NONE by default. Thus, one must explicitly specify SPLFDTA(*ALL) on a native IBM i backup process in order to save these.


How do we go about mimicking the same behavior in Commvault? As a side note, simply excluding all Out Queue Objects (OUTQ) is not a valid option.







Best answer by Rick T. 18 April 2022, 22:59

View original

If you have a question or comment, please create a topic

2 replies

Badge +1

Hello sperez_ca,

By default, the option to back up spooled files is disabled.
In the Commvault logs on the IBMi client you'll see "SPLFDTA(*NONE)" reported during the backup.

To change or verify this, do the following in the Commcell Console Java GUI:
- View the properties of the IBMi subclient.
- Click on the Advanced button at the bottom.
- Click the Advanced Options tab.
- In the 'Backup library objects' section, 'Spooled file data(SPLFDATA)' should be unchecked.
- If you want the spooled files backed up for this subclient, then enable that option.

You can read more about this here:

Note: Only if Spooled files are backed up can you restore them.  So the restore option to restore spooled files will only work if you set this option for the backup first.

Any further questions, please let us know.


Rick T.
Unix Tier 2 Support

Badge +1

Thank you Rick. I’d totally missed that.