Solved

Snapshot creation is disabled on [Server name] by []

  • 20 September 2023
  • 44 replies
  • 4523 views

Userlevel 2
Badge +6

Hi all.

 

After upgrading to 11.32.13 we are sporadically starting to see the below error when doing Vmware snapshot backup. The backup job fails or completes with errors:

 

“Snapshot creation is disabled on [Server name] by [].” 

 

Snapshot creation is not disabled for the server, and when backup is re-run everything is working.

 

Have anyone else seen this behavior?

 

Regards

-Anders

 

icon

Best answer by Sebastien Merluzzi 20 September 2023, 12:03

View original

44 replies

Badge

We had our issue resolved.. Problem was the additional key was added at the cs level by the team. 

After adding it to ma level, it fixed our issue

Badge +5

We are on 11.32.49 and still had this issue intermittenly. 
Will there be a hotfix for this issue instead of just the workaround?

Badge +1

Worked for us. Still think that masking a warning message, instead of addressing the issue is not a fix...

Badge

Hi 

We are on 11.32.45 and still have this issue. 

Could see this was addressed in 11.32.28 itself, anyone else with similar issues? 

 

Thanks, 

Diwakar

Tried with adding the key as well, which didn't help

Badge

Hi 

We are on 11.32.45 and still have this issue. 

Could see this was addressed in 11.32.28 itself, anyone else with similar issues? 

 

Thanks, 

Diwakar

Badge

Hi @SSchmidt ,

That’s correct, it is already fixed.

You can set the key as a workaround, however the issue can also be different.

So you may log a case with SUpport so we can check & confirm.

Best Regards,

Sebastien

Adding the key means that commvault does not perform the bVerifySnapshotCreationAllowed check, but it performs the backups anyway.

Badge +1

Same issue at 1.32.45. Ramdom VM getting this warning snapshot is disabled.

 

Hi, I made a ticket to the support this week, and they told me to add the key as indicated in this topic.

It worked and I don't get these errors anymore.

Unless they tell me it’s a false positive, masking the error/warning in the log, doesn’t fix anything.

Badge

Same issue at 1.32.45. Ramdom VM getting this warning snapshot is disabled.

 

Hi, I made a ticket to the support this week, and they told me to add the key as indicated in this topic.

It worked and I don't get these errors anymore.

Badge +1

Same issue at 1.32.45. Ramdom VM getting this warning snapshot is disabled.

Userlevel 6
Badge +14

@johann 

You should not need to, you can check with VMware Team so they can check and confirm and then if needed log a case with Support so we can check.

Badge

Hello, I have the same error messages since I upgraded to 11.32.49.

Should I add the Key on the media agents?

Userlevel 6
Badge +14

@SSchmidt 

I see your case is now closed.

Whatever issues was present before is no longer occurring.

Userlevel 6
Badge +14

@pdpelsem @UZ Gent ICT 

It looks like a different issue then, you can either log a case with VMware or Commvault, they/we will check.

Badge

@UZ Gent ICT

@Egor Skepko

You do not need to restart the commvault services for the additional setting to take effect.

32.28 will be out next week.

But we are already on a higher version (11.32.42) and still have the issue.

Userlevel 6
Badge +14

@UZ Gent ICT 

@Egor Skepko

You do not need to restart the commvault services for the additional setting to take effect.

32.28 will be out next week.

Badge

We have the same issue.

Set pending cause [Snapshot creation is disabled on [xyz] by [].]:

If we retry the backup it works.

We are running version 11.32.42 , so it should have been fixed already?

Userlevel 2
Badge +12

send via pm

Userlevel 6
Badge +14

@SSchmidt Excellent, what is your case number please?

Userlevel 2
Badge +12

Hi,

 

case is open and i set the key. 

 

Also i added an new schedule for backup failed vms only to cover this issue. 

 

Lets see what the support find out.

Userlevel 6
Badge +14

Hi @SSchmidt ,

That’s correct, it is already fixed.

You can set the key as a workaround, however the issue can also be different.

So you may log a case with SUpport so we can check & confirm.

Best Regards,

Sebastien

Userlevel 2
Badge +12

Hi All,

 

as per documentation: 

https://documentation.commvault.com/v11/expert/files/service_pack/updates/11_32_35.htm

 

The fix should be Included from Maintenance Release 11.32.28 (Nov 07, 2023) and all after. We are running 11.32.35 and have the problem. 

 

Do you know something about that ? 

 

Is the way now set the key ? 

Userlevel 6
Badge +14

ok, so the path is the category, VirtualServer

Just need to add the Additional Setting,

Badge +1

Hi Sebastien

 

Thanks for the prompt response, I cannot update to the latest MR as there is a strict Change Control/Freeze in place at present.

So the Key workaround would help.

Userlevel 6
Badge +14

HI @AndyC ,

The key is a workaround, can you upgrade to latest MR?

Badge +1

@Egor Skepko

You set it on the VSA/MediaAgent.

 

additional key:
Name: bVerifySnapshotCreationAllowed
Category:VirtualServer
Type: Integer
Value: 0
 

Do you have the Path on the MA where this Key is set? - I’m having the same issue !

Reply