Solved

Unable to change value of "sparse support" checkbox in Disk Library

  • 18 July 2022
  • 6 replies
  • 776 views

Userlevel 2
Badge +9

Hello,

We just added more storage to a mediaagent, via a new mount path in an existing disk library. The new mount path is an SMB share from a Dell Isilon, and the admin of the isilon confirmed they had enabled sparse support for the share - but he turned it on, after I’d already added the mount path.

As this user in the Commvault forums described, I should just be able to check/uncheck the checkbox for ‘sparse support’ right? It is not working for me though. What is the trick to changing the status of this checkbox? Are there other ways via the Web Command Center, or CLI, to do the same thing?

I also don’t see any means in the ‘properties’ of this mount path to enable this.

 

 

icon

Best answer by ZachHeise 18 July 2022, 21:08

View original

6 replies

Userlevel 7
Badge +17

Wondering if it will set this option when you cycle services on the media agent as it will check some basics regarding the mount path 🤔 Just a shot in the dark here.. Never had this enabled afterwards 

Userlevel 2
Badge +9

😑 hmm, not really something I can do while in the middle of an aux copy! If you’re pretty sure on that @Jos Meijer please confirm; I’d love to activate this setting WITHOUT a full service stop/start on this mediaagent.

Userlevel 2
Badge +9

There’s nothing IN this new device_59 right now. Would it be better if I just deleted it and made a new device on the SMB share, now that sparse is turned on? Commvault should detect sparse capabilities at time of creation, right, and check that properly this time?

Userlevel 7
Badge +17

If the GUI allows you to delete it then go for it! Once deduplicated data is allocated you won't get a second chance.

Userlevel 2
Badge +9

Yes, deleting device_59 and adding the mount path again (creating a new device_60) did the trick. Sparse support is now checked.

Userlevel 7
Badge +17

Awesome 👍👍

Reply