Solved

Commserve failed to process Enterprise Metrics Reporting Server scripts.

  • 22 July 2021
  • 3 replies
  • 36 views

Badge +1

Hi all,

We have had a Commvault backup/archive solution for a few years now, Commcell server version11.20.46. Backups are running fine but the Commcell event viewer is showing a repetitive alert message “Commserve failed to process Enterprise Metrics Reporting Server scripts”.

We’re not Commvault specialists and don’t really know what Enterprise Metrics Reporting Server is or if it’s something we even need. We’ve certainly never intentionally tried to set up any of the scripts mentioned. Can anyone shed any light on this message and any action required?

Thanks, Neil

icon

Best answer by Stuart Painter 22 July 2021, 14:05

Hi @Neil P 

Thanks for the question and welcome to the Community!

For early V11 Commserve installations, Metrics Reporting Server was an additional product, requiring a separate license. But from SP14 onwards, this feature has been included with the Commserve and is used to collect data from the Commserve DB.

You have 2 options, both are configured in Control Panel > Private Metrics Reporting

https://documentation.commvault.com/commvault/v11/article?p=37700.htm

  1. Disable the feature so that metrics data collection processes do not run, which should prevent the events you are seeing from being generated
  2. Configure the URLs to point to the Commserve, (you can use internal hostname as it’s communicating with itself) so that these processes are able to communicate with the metrics reporting engine, which should already be running on the Commserve.

Thanks,

Stuart

View original

3 replies

Userlevel 6
Badge +13

Hi @Neil P 

Thanks for the question and welcome to the Community!

For early V11 Commserve installations, Metrics Reporting Server was an additional product, requiring a separate license. But from SP14 onwards, this feature has been included with the Commserve and is used to collect data from the Commserve DB.

You have 2 options, both are configured in Control Panel > Private Metrics Reporting

https://documentation.commvault.com/commvault/v11/article?p=37700.htm

  1. Disable the feature so that metrics data collection processes do not run, which should prevent the events you are seeing from being generated
  2. Configure the URLs to point to the Commserve, (you can use internal hostname as it’s communicating with itself) so that these processes are able to communicate with the metrics reporting engine, which should already be running on the Commserve.

Thanks,

Stuart

Badge +1

Hi Stuart. Thanks for the advice! As we’ve never used it previously we will just disable it for now until we have more time to look at what advantages it may provide.

Userlevel 7
Badge +19

@Neil P , definitely worth looking into.  All sorts of insight you will have access to.

Reply