Solved

Microsoft OneDrive Cloud Storage


Badge +1

Hi All,

I have an issue when adding a OneDrive cloud storage.
I am configuring via CommCell Console. If I enter Application ID, Tenant ID and Shared Secret and then click the Detect button I receive an error “ ### EvMMConfigMgr::onMsgCloudOperation() - Failed to check cloud server status, error = [[Cloud] The requested URI does not represent any resource on the server.  Message: Invalid hostname for this tenancy

Commvault support answer is “The cloud vendor should be able to help you with the right URL. This is outside Commvault unfortunately ”.
Does anybody have any experience using Microsoft OneDrive as a cloud storage?

Thank you,
Lubos

 

icon

Best answer by Ho-chi Chen 8 April 2021, 18:06

CV doesn’t support custom domain until sp23, if you use xxx@xxx.onmicrosoft.com for the account name and still failed then may go to the support and collect detail logs.

View original

11 replies

Userlevel 5
Badge +10

Hi @Lubos Dvorak 

Thanks for the question.

Can I just clarify one item in the log message:

Invalid hostname for this tenancy

 

Are you able to confirm the URI is correct for that particular tenancy? If you have multiple tenancies and applications, there may be a mis-match between them. The error suggests that maybe the URI is valid, but references a different tenant.

Thanks,

Stuart

Badge +1

Hi @Stuart Painter ,

Thanks for your response.

Actually I don’t know what is meant by the URI in this context 😞 Where can I find it, how can I check it, where to configure it…
Could you give me a hint?
I tried to add this cloud storage at the customer’s commcell using his tenant and in my lab using my company tenant and always got same error.

Thanks,
Lubos

Userlevel 1
Badge +4

I noticed issues configuring Cloud libraries from the Commcell Console. 

Support told me to use Webconsole instead, and it worked for me while it failed through Commcell Console.

 

Badge +1

@Laurent

Unfortunately OneDrive cloud storage is not listed as an option in Webconsole.

Userlevel 1
Badge +4

You are right, I did not check as I was convinced that Cloud features would be always available in webconsole first then in Commcell console. But I was wrong, in my v11SP21FR20, I can only find the Microsoft OneDrive Cloud library in Commcell Console.

Then I only found this doc, hope it would help ? 

https://documentation.commvault.com/commvault/v11/article?p=105524.htm

Userlevel 1
Badge +4

To troubleshoot, you might also browse the logs of the MediaAgent from which you’re trying to configure this Cloud library, and explore the Cloud-related logs, whose name start with CloudActivity- or Cloud

Badge +1

CV doesn’t support custom domain until sp23, if you use xxx@xxx.onmicrosoft.com for the account name and still failed then may go to the support and collect detail logs.

Userlevel 6
Badge +14

@Lubos Dvorak , have you had a chance to review @Ho-chi Chen ‘s reply?  Let me know if it still fails and you need to open an incident (send me the case number).

Thanks!

Badge +1

@Mike Struening It still fails. @Ho-chi Chen is right, in FR11.23 it works like a charm but I have to keep on FR11.22.
I am afraid I am not able to get proper format of the user account name. The documentation says:

The username must be provided in the following format: username@#tenant#.onmicrosoft.com

For example: myusername@mycompanytenantmytenantname.onmicrosoft.com

Could you or anybody else help me with constructing the username, please?

I’ve tried many attempts (e.g. lubos.dvorak@companycztenantlubos_dvorak_company_cz.onmicrosoft.com etc.) but no success. My OneDrive link is https://companycz-my.sharepoint.com/personal/lubos_dvorak_company_cz/_layouts/15/onedrive.aspx

 

Badge +1

As I said, OneDrive custom domain support was only added in Sp23, if you really need it in sp22, please open an incident with Commvault support.

Userlevel 6
Badge +14

Confirming that the support incident has been reactivated to assist @Lubos Dvorak .

Reply