Question

The parameter used for the current operation is not supported by the Operating System, OS Drivers or the underlying Hardware


Badge +1

long story short story we observe error “The parameter used for the current operation is not supported by the Operating System, OS Drivers or the underlying Hardware” in our environment 

 

It started few months ago and from this time it is more and more extensive. It already “survived” few MR updates

 

First thought that is connected with some backup types but it already spread to ddb backup or index backup ...also exist in FS backup or vmware backup ...Often see tat also inside AUX copies  or in livesync replication 

 

Second thought that mine MA’s OS is guilty so we changed many MA’s from 2012r2 to 2016 or even 2019 ….not help ….also play with many options from OS which not help also

 

Next thought went to base where we store backups which s CIFS shares on Synology (especially that no so long ago we changed OS on them to DSM7 (from previous DSM6) . Here we also checked many things as for example blocking to use SMB3 and use only SMB2 ….no helped ...strange is fact that we have many diffrent models so it cannot appear on all of them ...also guilty destination is wrong way as beside to Synology CIFS we Netapp cifs and problems also starts to appear there.

  

Av is also not a case as meantime test time we completely blocked it on MA’s 

 

Also situation when its happen is crazy ..for ex.  Backup of DDB  progressing ...Inside process for example 34% finished goes to pending ...then i will resume it and backup can finish with success or error appear again and then after next resume it will finish :( 

 

Of course  message “The parameter used for the current operation is not supported by the Operating System, OS Drivers or the underlying Hardware” is false as CV completely not saying which parameter it talk about.

 

I little frustrated as this is big environment (35 sites geographically propagated) and the same error appear in many of them ??? .  In past we had errors like for example chunks problems but always was easy to find as reason after it but here ..i lost so any suggestion will be more then welcome 

 

i forgot actually we are in 11.24.48 version

 


3 replies

Userlevel 5
Badge +12

You will probably get the fastest result by opening a support case @ commvault.
Support will probably need to raise the debug level and request you to perform send log files with DB in order to get the answer.

It can be quite complex/large amount of log files to analyze such issue
If you want you can share a log set of one of your machines here, but this will include a lot of system specific information and I don't know if this is allowed by your company

Badge +1

it should be that CV  should proceed in that way You described ..mean debug level examination but unfortunately all our case always finish that  CV finds problems on OS level and saying that we should check with OS vendor (MS) or storage vendor (Synology) ….unfortunately we didn't change here (of course tried to resolve in other OS like moving 2012 to 2019 )  so something must be changed on CV that we receive that in mass way :( ..anyway we will still search 

Badge +1

@Marcin_CF - I too work in a similar environment as yours and ran into the same error on a few occasions.  Although, this message is very generic; my general finding has been related to network issues when attempting to access the mount path on the storage array. The error you mentioned are usually accompanied with additional errors like err 22 & err 1205 (transient network issues), which can help isolate this issue further.  If you happen to find any additional errors when this issue occurs, please share them.

In conjunction with Jos recommendations, you can try to isolate the issue further by checking the following:

  • Test network speeds from media agent to storage
  • Test load balancing from media agent to storage using a ping sweep (if used - validate all IPs are available)
  • Verify storage controller is not oversubscribed during errors
  •  Check storage configuration for additional optimization - correct MTU settings, is adaptive workload in play.

Below is a powershell script that you can use to test load balancing from media agent. Please valid script in our test environment before running. 

##########################################

Write-Host "Checking the SC round robin functionality"
 
### Set Library or Zone Name ###
$SC = "AddYourlibraryNameHere"
 
Write-Host "Looping thru DNS/IP address of $SC"

### Doing 50 checks - IP address should change based on IP pool range that is configured ###
ForEach ($number in 1..50) {
 try {
  [System.Net.Dns]::GetHostEntry($SC)|Select-Object Hostname, AddressList
 }
 catch {
  Write-Host "Unable to resolve $SC" -foregroundcolor "red"
 }
 Start-Sleep -s 1
}

Reply