Exchange - DAG Discover failed

Badge +7



The exchange guys are in the process of setting up a new exchange cluster, so i am trying to add a new “Exchange DAG” client, but when i try to discover the servers an error pops up with “DAG Discover failed”. 

I’ve also tried using a proxy, but i get the same error.


So, i guess the question is, which log-files should i try to dig into to try and locate where and what the problem with this is ?



Best answer by Bjorn M 27 April 2022, 15:00

View original

If you have a question or comment, please create a topic

16 replies

Userlevel 6
Badge +14

Good morning.  Please make sure that the account you are using is an Active Directory Domain Admin ( Domain/account) in the DAG client configuration account to discovery Exchange entities in AD during LDAP query.
- Is LDAP connection over Port 389 is open from commserve to AD? It needs to be opened for us to do a discovery. Can you use ldp (command from commserve) to confirm that we are able to connect/bind to the DC of your AD with the account you are trying to use for DAG Configuration?

You can use this tool, or MS ldp that is build in most system.

Please make sure the DAG node client names are FQDN and not short name.  

Badge +7



Where in the “Exchange DAG Client” (when adding a new client) can you specify username/password for the account used ? I do not see any option for that.

However, on the old client (that already exists, i can see an option in Properties, Advanced, Database Member Servers, but that option is not shown when trying to create a new client)


LDAP seems to be open, and i can see traffic passing through in the firewall logs when i try to do a discovery.


As for the DAG node client names, i’ll check with the exchange/ad guys if they can confirm.



Userlevel 6
Badge +14

Please review this resource on creating an Exchange DAG client:

Badge +7

Thank you, will try going through the web-interface. So far i’ve used the “classic” java client/console.

Badge +7

Hmm, strange, in Command Center, when i go to Protect > Applications > there is no exchange option. The only options listed is Office 365, DevOps, Salesforce and Sharepoint.



Userlevel 6
Badge +14

Have you reviewed this resource as well:


Please let me know if you have any questions.

Badge +7


I have installed the exchange “agent” on the 2 nodes in question, I’ve added an “exchange database” to them, and if i look at properties and contents for the default subclient, i can see the Microsoft Information Stores (4 in this case). So everything looks fine on each of the clients. 

It’s when i’m trying to create the Exchange DAG pseudo-client where i just get the “DAG Discover failed”.


Userlevel 6
Badge +14

It is possible to have the local Exchange database agent work properly but the DAG discovery fail if the client has the hostname as short name as opposed to FQDN which is why I asked you to check that setting on the nodes.  You can check a log file ExtiDbDiscover.log on the DAG nodes for the cause of the failure.


Badge +7

@Orazan By client, do you mean the client of each node (which are basicly “hostname10” and “hostname11”) …. 

So for each of the 2 physical clients, under general/properties they have the following (sanetized names)

Name: hostname

Display Name: HOSTNAME

CommServe HostName: FQDN to commcell.

Host Name: hostname.domainname.countrycode


So they both have the FQDN as the “Host Name”. The display name however is the short name.


However, if i look in the logfile you mentioned on the 2 physical nodes i do se the following (and the same for the second server, just different hostname and database name):


28000 54a8  04/08 14:06:15 ### [::main]: *** Exchange Server Name: 'hostname10'. ***
28000 54a8  04/08 14:06:15 ### [::GetDBNames] passive copy database found: [MDB102]
28000 54a8  04/08 14:06:15 ### [::GetDBNames] passive copy database found: [MDB104]


So in that log-file, it seems to be using the short name, and not the FQDN for some reason.

Userlevel 6
Badge +14

In the subclient properties, do you have the option to use passive copy only configured or is it set to use the active copy if no passive copy is found?

Badge +7

@Orazan Those options are on the “Server Selection Tab” …. which i do not have, because i have not been able to create the “Exchange DAG” pseudo client, because i cannot perform a discovery ….. so the “ok” button to create it is grayed out.

And on the physical nodes themselves, that tab/option does not exist as far as i can see.



Hello Bjorn,

I have exactly the same problem:

Java Console shows “DAG discover failed”.

Commandcenter does not show Exchange under Applications.

An older DAG (created years ago) is running fine.

I´m on Version 11.24.34.

Could you fix this in the meantime?


Badge +7

@Martin Koenig


For us, the main domain/service account was still listed with just “username” instead of “domain\username”. 

Once i changed/edited the account from just “username” to “domain\username” (CommCell Browser > Security > Domains and Organiations > “domainname” ) i was able to do a DAG discovery.




@Bjorn M 


Thanks for this hint! 

It´s discovering now as expected! 💪


Badge +1

Thanks, this worked for me too. After updating the user I was able to successfully discover the DAG.

Userlevel 7
Badge +23

Glad to hear it @jakubkluba !  If you haven’t already, can you click the smiley face/helpful button?  This ensures it gets more attention from search results.