Solved

Ignore pg_dump


Userlevel 2
Badge +11

During the backup I have issue: /opt/PostgreSQL/8.3/bin/pg_dump: unrecognized option `--lock-wait-timeout=60000'

Commvault  11.20.46
Postgres SQL 8.3 

I know that the new version of Comvault no longer supports this version of the databases

 

I have a question, is it possible to modify the pg_dump command in Commvault? (to omit an unrecognizable option) Alternatively, how can the following problem?

icon

Best answer by Sunil 10 May 2021, 14:46

View original

4 replies

Userlevel 3
Badge +6

Hi ,

There is no workaround for this. There is no provision to remove a default parameter passed with pg_dump . 

 

How many postgresql instances do you have with version 8.3? and what is the upgrade plan? lock-wait-timeout was introduced in postgres 8.4

 

Regards,

Meera

Userlevel 5
Badge +11

Hi @kszaf 

There is no way to skip this argument. Also, it’s not advisable to backup PostgresSQL 8.3 using v11 client. You can install a v10 client pointing to v11 CommServer to backup this version.

 

Thanks,

Sunil

Userlevel 2
Badge +11

Thanks for help!

 

Userlevel 2
Badge +11

Thanks for help!

 

Reply