Solved

PostgreSQL Backup stuck at 88%

  • 11 January 2022
  • 2 replies
  • 60 views

Userlevel 3
Badge +10

Hello, 

once again I have a strange problem. We have set up a PostgreSQL backup and wanted to create an initial full backup. Data was transferred and everything looked good so far. However, at 88% the job stops. Under Log for the Job I only get this information. 

23258 5ada 01/11 16:34:15 3840492 IDXCONNECT *****************USING NEW INDEXING LAYER**************
23258 5ada 01/11 16:34:15 3840492 IDXCONNECT Stream Id not set, Generating it
23258 5ada 01/11 16:34:15 3840492 IDXCONNECT Initializing Indexing connection to client [cvmapapp01] from [fxvsdpg2], Setting log mode as offline
23258 5ada 01/11 16:34:15 3840492 CVArchive::ConnectSessionToArchiveManager() - Attaching to CommServer [cvcspapp01] from Platform Type 4
23258 5ada 01/11 16:34:15 3840492 CVArchive::ConnectSessionToArchiveManager() - Attached to CommServe
23258 5ada 01/11 16:34:15 3840492 IDXCONNECT starting afile (2,194,8136411)
23258 5ada 01/11 16:34:15 3840492 CVOnDemandSvcClient::SubmitTask() - On Demand service CVODS_logmanager_cvmapapp01_1 launched at host cvmapapp01*cvmapapp01*8400*8402. Unique ID is 0120018F-4E08-4B7C-9FEA-F5A8192A68C9
23258 5ada 01/11 16:34:15 3840492 Got ODS Guid [0120018F-4E08-4B7C-9FEA-F5A8192A68C9] from server [LogManager] Host [cvmapapp01*cvmapapp01*8400*8402]
23258 5ada 01/11 16:34:15 3840492 IDXCONNECT entire afile (2,194,8136411) is valid
23258 5ada 01/11 16:34:15 3840492 CVOnDemandSvcClient::Attach() - Successfully attached to on Demand service CVODS_logmanager_cvmapapp01_1 launched at host cvmapapp01*cvmapapp01*8400*8402. Unique ID is 0120018F-4E08-4B7C-9FEA-F5A8192A68C9
23258 5ada 01/11 16:34:15 3840492 IdxUtil::addBrowseAblePathIndV2() - calling idx.backupDone(1)
23258 5ada 01/11 16:34:15 3840492 CVOnDemandSvcClient::Attach() - Successfully attached to on Demand service CVODS_logmanager_cvmapapp01_1 launched at host cvmapapp01*cvmapapp01*8400*8402. Unique ID is 0120018F-4E08-4B7C-9FEA-F5A8192A68C9
23258 5ada 01/11 16:34:15 3840492 PGPERFMONITOR::PGTimer::logSummary(433) - Function/query   #of calls  Elapsed Time(sec)
23258 5ada 01/11 16:34:15 3840492 PGPERFMONITOR::PGTimer::logSummary(436) - sendMetadataIndex   1  0.203651
23258 5ada 01/11 16:34:15 3840492 PostGresClBackupBase::exitHere() - DBG: sendDirChange with finalize called
23258 5ada 01/11 16:34:15 3840492 NoPrefix Heartbeat timeout is set to 1800
23258 5ada 01/11 16:34:15 3840492 *******************Using new Indexing layer*******************
23258 5ada 01/11 16:34:15 3840492 [::sendDirChange]: creating one line dirchange
23258 5ada 01/11 16:34:15 3840492 [::sendDirChange]: createindex will process dirchange [/opt/commvault/Base/Temp/Idx_23258_1]

Has anyone encountered this problem before and could it be solved ? We have already reinstalled the agent but again without success. Our database admins don't have a solution either.

with kind regards

Thomas

icon

Best answer by Meera 11 January 2022, 18:48

View original

2 replies

Userlevel 2
Badge +5

Hello Thomas,

 

We may see this hang when log archival doesn’t work properly. Can you please verify log archival is fine by running the following queries:

 

select pg_start_backup(‘Testing’);
select pg_stop_backup();

 

These should complete fine and you should see the transaction logs archived to WAL directory when second query completes. If second query hangs, archive_command in postgresql.conf need to checked and user, write permissions to it need to be checked.

 

Regards,

Meera

Userlevel 3
Badge +10

Hello @Meera , 

thanks to your post we could solve the Problem. 
Thank you 

with kind regards

Thomas

Reply