Solved

Postgresql - Version 14 support

  • 25 November 2022
  • 3 replies
  • 88 views

Badge +3

Hi 
 

The latest version of PostgreSQL is now 15 - Can i not backup Postgres 14 databases with commvault?
 

I currently have 30+ AWS Aurora Postgres clusters all running Postgres 14.  (version 14 has been out for more than a year)

Mike

icon

Best answer by Meera 25 November 2022, 03:47

View original

3 replies

Userlevel 3
Badge +6

Hi Mike,

 

When a version is completely supported, we do not have a requirement of PostgreSQL application to be installed in the access node (to use the binaries like pg_dump, pg_restore etc.). Install will be copying these required binaries to commvault install location, under CVCloudAddOns folder.

 

For PostgreSQL 14, this is supported from SP30. Until SP 30, please install PostgreSQL application (version 14) on access node (server does not need to be initialized, only binaries need to be present in access node) and from commcell console, set the install path under Cloud Configuration tab as explained here:  https://documentation.commvault.com/11.24/expert/115954_configuring_postgresql_database_version_of_proxy_client_computer.html

Badge +3

Hi Meera

Thanks for the reply. I’ve added the binaries and everything appears to work now :)

Can you let me know what will happen when we come to apply SP30 and PostgreSQL 14 already exists?

Also is commvault clever enough to know if a Postgres version has been upgraded? I manage multiple postgres clusters  (versions 10 - 14) and if we upgrade a cluster will commvault pick up the change?

Thanks,

Mike

Userlevel 3
Badge +6

Hi Mike,

The current version of instance will be identified and updated with next full backup.

Reply