Solved

question about application Class 1 license


Userlevel 1
Badge +10

Hello,

 

I have some question about application class 1 lincense.  I have installed around 400+ sql  in commvault and if i look to my License summary then i see like 6 sql clients onder te tab Application Class 1. And that not what i want because its using client license.

On the sql client i have instal only sql software and after full back i have released license for file system.

 

I do find Mirosoft Sql server on Components in the Application Class Licenses for Application class1. But why another 395 installed sql clients are not listening in license summory onder Application class 1 ?

 

icon

Best answer by Egor Skepko 2 July 2021, 14:35

View original

25 replies

Userlevel 7
Badge +15

Hi @Egor Skepko 

Thank you for the question, we will need a little more detail to understand fully.

It is expected that a physical server running SQL agent will consume an App Class 1 licence.

If you have a VM running SQL and performing AppAware backups, then the App Class Virtual licence is consumed instead.

So, it really depends on the client machine, whether this is physical or virtual and if AppAware is configured to protect those clients?

Thanks,

Stuart

Userlevel 1
Badge +10

Hi @Stuart Painter ,

 

Thank you for your answer. They all are vm's and not physical server. And i am doing only sql backup normal not a AppAware backup. What kind of information do you need more so i can check? 

Userlevel 7
Badge +15

Hi @Egor Skepko 

Depending on the licence model you have, these VMs may be licenced by VM instance or by Hypervisor socket - and so not consuming App Class 1 license.

The few clients that are consuming App Class 1 may be either physical servers or not covered by another licence, e.g. VM or socket.

Thanks,

Stuart

Userlevel 7
Badge +23

@Egor Skepko , are you backing the vms up through the Virtual Server Agent, or by installing the SQL iDA?  It all comes down to how you are protecting the data.(as a vm or as a server through SQL).

Userlevel 1
Badge +10

@Mike Struening By installing SQl IDA

Userlevel 7
Badge +23

@Egor Skepko can you run a License Summary Report and share the content?  Depending on the Commserve version and your licensing model, the answers will vary :nerd:

Userlevel 1
Badge +10

@Mike Struening  Here is the license report 

Userlevel 4
Badge +8

@Egor Skepko I am not able to access the report. But in the meantime, can you run license summary report and select the option Application Class Virtual. Do all of the other SQL servers show up here. If so then based upon that you are either licensed for Hypervisor sockets or Virtual Operating Instances. As with these 2 licenses the SQL agents will not count toward capacity being they are installed on VM2 that were discovered or backed up under these. The SQL agents under Application Class 1 are either physical machines or VM’s that are not backed up or discovered under these licenses.

Userlevel 1
Badge +10

@Edward here is the result of report. and you right the sql what i see under application class 1 are not listed here. The are not physical machines. How do  i get right way that the wil be discovered under wright license?

Userlevel 4
Badge +8

@Egor Skepko I am still not able to access the reports, please run the following license summary reports, Run one picking the Sockets option and run a second picking virtual operating instances. Do you see the server listed in Application Class one listed in either of these reports. 

 

Userlevel 1
Badge +10

@Edward Hmm u cant open attechment wich i uploaded to the case?

Userlevel 4
Badge +8

@Egor Skepko No for some reason I get network errors when trying to open them to save them.

 

Userlevel 1
Badge +10

@Stuart Painter @Mike Struening Can you open the attachement ?

Userlevel 1
Badge +10

@Edward ok that wierd, i can open from different computers. But i made 2 report and i do see sql onder application class 1 from 2 differents report

Userlevel 4
Badge +8

@Egor Skepko if you run report for Just VM Socket and run report for Just Virtual Operating instances do the servers that show up under Application Class 1 show up on either of those reports.

Userlevel 1
Badge +10

@Edward Yes i see them under Virutal Operation Instances report but not under VM socket. Under Vm socket i see on Hypervisor's

Userlevel 4
Badge +8

@Egor Skepko Please check the Summary section on the report for the Virtual Operating Instance you should see something like this;

 

If you do and are running under this license and see the server listed under Application Class 1 list in the Virtual Operating instance please open case for support to investigate this further.

Userlevel 7
Badge +23

@Egor Skepko I’ll second what @Edward said.

I was able to open the report, though it’s likely that it wasn’t fully synched/available yet earlier in the day.

Here’s the section he is looking for:

Virtual Operating Instances 0 44 N/A

I can see that your servers are all listed under Application Class Virtual (small screenshot below).

Is this where you’re seeing thats erver?

 

Userlevel 1
Badge +10

@Mike Struening Yes i see there phew sql the same as under application class 1

Userlevel 1
Badge +3

Hello @Egor Skepko,

 

I have been looking at the report you provided and I would like to know if your only concern is that there are discrepancies in how the licenses are being used or if you have a larger concern?  Example: If you have enough licenses purchased.  

Userlevel 1
Badge +10

@byates Yes the question is why some of sql agents using application class 1 license. If i can figure it out then i can save like 350GB+ of capacity

Userlevel 1
Badge +3

@Egor Skepko.  Thank you for the information.  At this time, I would recommend creating a case for us to research deeper.  The license report you provided does not have enough information to provide an educated answer to your query.

Userlevel 7
Badge +23

Hey @Egor Skepko , let me know the case number once you get one created.

Thanks!

Userlevel 1
Badge +10

@Mike Struening de case nummber is HDS02909064 or 210630-339

Userlevel 1
Badge +10

Thanks everyone the probleem is solved. The issue was that vm where sql was installed was not detected by VSA. Because the vm name(hostname) where sql agent was installed was different from the vm wich was detected by VSA. I juist reinstalled sql client in commvault. 

Reply