Question

Workflow SMTP Error - 19:857

  • 22 January 2024
  • 18 replies
  • 224 views

Badge +2

Hello! All good?
My name is Filipe Asaph, work in StorageOne.

I would like to ask you questions about Commvault's "Workflow" tool. I'm trying to send an email in Workflow, but it always gives an error. The error number is 19:857.

Grateful, Filipe Asaph.


18 replies

Userlevel 3
Badge +6

Hi Filipe,

Have you configured your mail server under Manage > Commcell and does the test email succeed?

If so, it may be because WorkflowEngine tries to talk directly to the SMTP server by default, rather than going through the Commserve. You may need to set sendWorkflowEmailsViaCommserver if the CS is the only server able/allowed to communicate with your SMTP server.

Badge +2

Hi Carl,

I carried out all these procedures, but the error persists... could there be another type of error?

 

 

Userlevel 3
Badge +6

What does the SmtpManager.log on the CS show at the time of failure?

Badge +2

 

 

Badge +2

Hi Carl, 

This message appeared:

“WorkflowMail            : [Email (Email_2)] ERROR: failed to relay email, errorCode [587206208], errorMessage [Failed to send email to SMTP Mail server, please check logs for more details]”

Userlevel 3
Badge +6

If you increase the debug level on that log to 20, the log should show the entire SMTP “conversation” which will help us determine the source of the error.

 

From the message you have so far, it’s not clear if Commvault failed to reach the mail server, or if the mail server rejected the connection because it thinks the source or destination are outside of its scope.

Badge +2

Hi Carl! All good?

 

Below is the attachment with the workflow log that we are testing. Could you help us?

 

Greetings, Filipe.

Userlevel 6
Badge +17

One thing I’m seeing a few times in other tickets, verify the From: address is valid in the Email component of the workflow.  It’s possible the SMTP server is rejecting the connection if the workflow is sending an invalid From: address.

Thanks,
Scott
 

Userlevel 6
Badge +17

Also, search the EvMgrS.log for “smtp” and see if you get more details.  I believe the actual commands (and responses) used to make the SMTP connection are logged in that file.


Thanks,
Scott
 

Userlevel 3
Badge +6

Hi Carl! All good?

 

Below is the attachment with the workflow log that we are testing. Could you help us?

 

Greetings, Filipe.

Hi Filipe,

I'll need to see SmtpManager.log at debug level 20 as I mentioned above. WorkflowEngine.log doesn’t contain the interactions with the SMTP server.

Badge +2

Hi Carl,

I'm now sending SmtpManager.log at debug level 20 as you asked.

Grateful, Filipe

Userlevel 6
Badge +17

Based on other TRs with the same error, try setting sendWorkflowEmailsViaCommserver = 1.

sendWorkflowEmailsViaCommserver
https://documentation.commvault.com/additionalsetting/details?name=%22sendWorkflowEmailsViaCommserver%22&id=2278

“Configures the workflow engine to send all emails through the CommServe server instead of directly sending the emails from the workflow engine.”

Thanks,
Scott
 

Userlevel 3
Badge +6

Hi Carl,

I'm now sending SmtpManager.log at debug level 20 as you asked.

Grateful, Filipe

Hi Filipe,

Your SMTP server is rejecting the credentials you’ve provided:

SmtpCmdResp: 535 5.7.139 Authentication unsuccessful, the request did not meet the criteria to be authenticated successfully. Contact your administrator. [CP6P284CA0025.BRAP284.PROD.OUTLOOK.COM 2024-01-31T18:31:23.140Z 08DC21863B6CFA61]
--readSmtpResponse
SMTP authentication failed after sending password.
Check your username/password or your SMTP server's auth settings

If not a problem with the credentials themselves, it could be that your SMTP server has other requirements that aren’t met.

I noticed this message a couple times, but I don’t know if it would make any difference for this issue:

Try using smtp.live.com instead.

 

Badge +2

Good afternoon Carl, how are you?

I checked that my credentials are not incorrect, I also tried using "smtp.live.com" but the test was negative.

 

Below is the error message.

 

Userlevel 3
Badge +6

Hi Filipe,

You would need to work with the Exchange admin to determine why the SMTP server is rejecting this connection. It must have some sort of security requirement that’s not being met, but all it’s telling us is bad password.

Userlevel 6
Badge +17

Based on other TRs with the same error, try setting sendWorkflowEmailsViaCommserver = 1.

sendWorkflowEmailsViaCommserver
https://documentation.commvault.com/additionalsetting/details?name=%22sendWorkflowEmailsViaCommserver%22&id=2278

“Configures the workflow engine to send all emails through the CommServe server instead of directly sending the emails from the workflow engine.”
 


Did this setting not help?

Thanks,
Scott
 

Userlevel 3
Badge +6

@Scott Moseman, if you scroll up you’ll see it’s the first thing we tried.

Userlevel 6
Badge +17

@Scott Moseman, if you scroll up you’ll see it’s the first thing we tried.


OK, roger that, I must have overlooked that update.

Thanks,
Scott
 

Reply