Solved

Failing Exchange Backup after Commvault upgrade - Did not find an exchange server with IDA installed, No Exchange Server available


Userlevel 4
Badge +13

Hi all,

after Commvault software upgrade to 11.32.49 Exchange backup is failing with the following error alert - Error - Did not find an exchange server with IDA installed, No Exchange Server available. Indeed, it is not possible to discover active DAG servers. There are only some DAG servers greyed out. However, when trying Check readiness, all seems to be ready. Additionally, we have tried to unistall and install client Commvault software again. Moreover, when tried to add again Exchange client from Client Computer → New Client → Exchange DAG Client → Discover - DAG Discover failed.

 

Do you have any idea how to troubleshoot this issue? Any help will be much appreciated!

 

icon

Best answer by drPhil 3 June 2024, 13:28

View original

2 replies

Userlevel 6
Badge +15

Hi @drPhil 

That’s interesting… I’d probably raise a support case if possible to try identify what has changed in this release that prompted this issue.

Before you try to add the DAG node, could you ensure the DAG members have the exchange agent installed and configured?

Installing the agent won’t be enough, you’ll need to ensure the agent itself is configured as per: https://documentation.commvault.com/2023e/expert/adding_exchange_database_agent.html

 

Please let me know if that helps?


Regards,

Chris

Userlevel 4
Badge +13

The backup error that prevented Exchange backups from running, which occurred after updating the Commvault software, was only resolved after collaborating with Commvault support. It seems that the VM client ID associated with individual DAG members changed after the update, so it was necessary to assign the old ID to the current members. They advised us to use these commands, after which it was possible to reassign the DAG clients to the Exchange pseudoclient through the CV console.

qoperation execscript -sn QS_SetVMClient -si @Client1='BCDLMA01K_1' -si @Client2='BCDLMA01K'

qoperation execscript -sn QS_SetVMClient -si @Client1='BCDLMA02K_1' -si @Client2='BCDLMA02K'

Reply