Solved

NTP on Hyperscale

  • 25 January 2022
  • 8 replies
  • 753 views

Userlevel 1
Badge +6

Hi,

 

I have 2 questions related to the same issue.

We have an hyperscale with 3 nodes. When we look at the mountpath we have 3 shares of which 2 are online and the 3th offline. If you validate this share it comes with the following message:

Failed to check cloud server status, error = [[Cloud] The request time is too skewed. Message: The difference between the request time and the server's time is too large. Resource: /*******?delimiter=%2F&prefix=*******%2F Extra Details: RequestId 1643106149072049 ]

When I gave the command timedatectl we found out that the node was a litte bit over15minutes behind and the other 13min behind. I think 15min is reason to take the share offline for that node.

My questions are:

  1. Can/may I set the time with the command “date --set”<correct time>”
    Does this come with a risk? Do I need to stop the CV services first for example?
  2. Are Hyperscale nodes not default configured with a NTP server, same as Commserve for example? 

All my Linux knowledge is from Google, so please treat me like a dummy in this case :grinning:

 

Thanks,

Danny

 

icon

Best answer by HenkR 31 January 2022, 16:08

View original

If you have a question or comment, please create a topic

8 replies

Userlevel 4
Badge +8

Hi @Danny 

  1. Can/may I set the time with the command “date --set”<correct time>”
    Does this come with a risk? Do I need to stop the CV services first for example?

It would be better to use NTP server rather than setting time manually. It can be global or internal. Would suggest to stop the CV services prior.

  1. Are Hyperscale nodes not default configured with a NTP server, same as Commserve for example?

The default time zone is EST for HyperScale.

Userlevel 1
Badge +6

Hi @Danny 

  1. Can/may I set the time with the command “date --set”<correct time>”
    Does this come with a risk? Do I need to stop the CV services first for example?

It would be better to use NTP server rather than setting time manually. It can be global or internal. Would suggest to stop the CV services prior.

  1. Are Hyperscale nodes not default configured with a NTP server, same as Commserve for example?

The default time zone is EST for HyperScale.

Hi,

Thank you for your reply.

I understand NTP is the best way. But it seems not to work. From my understanding, if NTP is configured there must be an timesyncd.conf. This is not there.
So, my question, is NTP by default configured on a hyperscale-node. And if so (or not) how can I determine this. Maybe a FW-rule must be created.

And to bring the share online, I need to modify the time. So, stop CV services on that node, modify time and start services come without any risk?

Danny

Userlevel 2
Badge +4

Hi @Danny 

  1. Can/may I set the time with the command “date --set”<correct time>”
    Does this come with a risk? Do I need to stop the CV services first for example?

It would be better to use NTP server rather than setting time manually. It can be global or internal. Would suggest to stop the CV services prior.

  1. Are Hyperscale nodes not default configured with a NTP server, same as Commserve for example?

The default time zone is EST for HyperScale.

Hi,

Thank you for your reply.

I understand NTP is the best way. But it seems not to work. From my understanding, if NTP is configured there must be an timesyncd.conf. This is not there.
So, my question, is NTP by default configured on a hyperscale-node. And if so (or not) how can I determine this. Maybe a FW-rule must be created.

And to bring the share online, I need to modify the time. So, stop CV services on that node, modify time and start services come without any risk?

Danny

Hello Danny,

NTP is installed and not configured by default, it must be configured on the nodes.
This is done at /etc/ntp.conf

Userlevel 1
Badge +6

Thanks for all the replies,

It is not yet all clear for me, but I am going to check

Userlevel 2
Badge +5

Hi,

 

Did some “time” configuration on my part on a Hyperscale 1.5 node (new)

timedatectl set-timezone Europe/Amsterdam

ADDED my NTP server in /etc/ntp.conf (disabled default ntp servers)

systemctl enable ntpd.service

systemctl stop ntpd.service

ntpd -gq

systemctl start ntpd.service

systemctl status ntpd.service
 

NTPD service is running fine but after reboot the service is inactive.

Any ideas here why the deamon does not start on reboot.
[root@node-4 ~]# systemctl status ntpd.service
● ntpd.service - Network Time Service
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
   Active: inactive (dead)

Userlevel 2
Badge +5

Did some further research and here is what I found out.

The default  Hyperscale 1.5.1 image deployment consist of two ntp services (ntpd and chronyd)

By starting the server chronyd will start first so NTP cant, by disable chronyd NTP will start.

systemctl stop chronyd

systemctl disable chronyd

 

Also added this:

timedatectl set-ntp yes

 

After restart the server NTPD starts and after a while it's synchronized.


      Local time: Mon 2022-01-31 16:02:49 CET
  Universal time: Mon 2022-01-31 15:02:49 UTC
        RTC time: Mon 2022-01-31 15:02:49
       Time zone: Europe/Amsterdam (CET, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no

 

Not sure if this is correct, but it works for me.

Strange that Commvault installation documentation recommend you to set your NTP straight but does not document how to do it…….

Userlevel 7
Badge +23

Appreciate the share of the solution, @HenkR !

Userlevel 2
Badge +5

Additional,


When it comes to the CHRONYD time server I think this is a better one than the NTPD.

 

Set time zone:

timedatectl set-timezone Europe/xxxx

 

Disable NTPD:
systemctl disable ntpd.service
systemctl stop ntpd.service
systemctl status ntpd.service

 

Configure the time server in the /etc/chrony.conf file

vi /etc/chrony.conf

 

Start chrony services (chrony is default enabled)

systemctl status chronyd.service
systemctl list-units --type=service |grep chrony
systemctl stop chronyd.service
systemctl start chronyd.service

 

Check time results

timedatectl

 

If the time deviates to much you can restart the log service to get the log in correct time zone.
To check the logging time stamp do:
cat /var/log/messages

You can then do a reboot or restart log services.
systemctl stop rsyslog
systemctl start rsyslog
 

With Regards,

Henk