Oracle RAC allocate channel error after upgrade to SP20

Userlevel 1
Badge +7

Hi all,
After upgrading to SP20 the subclient shows the following error (the previous version was SP12):

[RMAN-06908: WARNING: operation will not run in parallel on the allocated channels]


The job ends successfully but with errors:


I noticed the problem during the archive log phase.

The Oracle RAC version is There are two physical node.


I have three RAC instances configured on three different Pseudo-clients that have the same two physical nodes. Strangely, one instance continues to function correctly after the upgrade despite having the same configuration in the Commvault environment as the other two.


Before with the SP12 I saw the same error in the RMAN Log, but it was not highlighted in the job. The job completed successfully (Green Status).

Even the instance that works correctly shows the same error in the RMAN Log but it is not highlighted in the job that ends correctly (green status).


Best answer by Mike Struening RETIRED 6 August 2021, 17:19

View original

11 replies

Userlevel 7
Badge +23

Hey @Gabriele Palumbo , hope all is well!

Do you also see the note about requiring Enterprise Edition?

If the restore destination is Oracle Standard edition not Enterprise - only 1 channel is supported.  you can retry with 1 channel and the restore should be successful.

RMAN-06908: warning: operation will not run in parallel on the allocated channels

RMAN-06909: warning: parallelism require Enterprise Edition

Userlevel 1
Badge +7

Hi Mike,The problem is on the backup not on the restore (for the moment).Compared to SP12 nothing has changed on the Commvault configuration and on the Oracle client configuration.

As I told you before everything worked fine.

How can I force the use of only one channel?

Userlevel 3
Badge +5

@Gabriele Palumbo,

In the older service packs, we were ignoring that warning message and let the backup run. But in the newer SP’s we wanted to highlight that error and make sure the stream info gets corrected to avoid any issues during the restore.

Could you please share the rman.log of both the completed job and failed jobs to review further?


Userlevel 1
Badge +7

Hi Mahender,  attached are the RMAN Logs, I remind you that the backup does not fail but ends with errors as you can see from the previous post.

However I had imagined that it could only be a warning message inserted in the SP20 but the customer wants to be sure of my explanation.

Userlevel 3
Badge +5

@Gabriele Palumbo ,

In the OK_SP12.txt log, the script allocated only 1 channel, and that was why it didn’t report any error.
In the WARNING_SP20.txt log, the script allocated 4 channels, and it reported the warming message as multiple streams are not allowed on non-enterprise Oracle servers.

You can try adding the below registry key to all the RAC physical clients that report those warnings.

Registry key name: sIGNORERMANWARNINGS
Category: OracleAgent
Type: String
Value: Y

The registry key ignores those warnings and marks the job as completed successfully. The backups that are marked as completed won’t have any impact on the restores.

Userlevel 1
Badge +7

Hi Mahender, thank you for your time.

Since I have not changed any configuration after the update I do not understand why 4 channels are now allocated instead of one.
In the subclient I have assigned only one stream for each instance.

How can I do to force the use of only one channel?

Also, as I had already written in my first post, on another pseudo-client I did not encounter this problem after the update despite being configured in the same way as the others.

Userlevel 3
Badge +5

@Gabriele Palumbo, Could you please open a support ticket and share the case number?
I need to perform a remote session and check this further.

Userlevel 1
Badge +7

Hi Mahender, unfortunately I will have to open the ticket with the Italian support to which the customer is linked and before starting an escalation it will take a few days. Anyway I will do it soon.

Userlevel 1
Badge +7

@Mahender Reddy I opened the case as your request, below the number: 210719-265

Whenever you want in the next few hours I am available for a remote session.

Userlevel 1
Badge +7

@Mahender Reddy, we sent you the last log you were waiting for. Strange thing, now even the RAC pseudo-client that didn't display the warning now does!

I look forward to hearing from you.

Thank you

Userlevel 7
Badge +23

Sharing the case resolution:

I have just reviewed the logs that you had uploaded yesterday.
It appears that the SITC database is also completing with warnings now.
As both SFIT and SITC are completing with warnings, I can say that these backups are now behaving as expected.

And to avoid warning messages, please use the sIGNORERMANWARNINGS registry key.