Question

problem for download PR2022E (11.28.24/32/33/34)

  • 23 November 2022
  • 9 replies
  • 990 views

Badge +1

Hello the community,

 

Since last week, i’m trying to download the last plateform release with the last HPk.

When i download from the commserv i have an error with a .py which haven’t the good checksum

\SP28_4489590_R1081\Windows\ThirdParty\Python\x64\Lib\installpythonmodules.py] has different checksum [1362643267] than the expected one [1248360684].

 

I also try to made a package from the installer on my computer and kaspersky have detected a virus in a file :
 

Nom: UDS:DangerousObject.Multi.Generic

Exactitude: Exactement

Niveau de menace: Élevé

Type d'objet: Fichier

Nom de l'objet: CvEdgeMonitor.exe

Chemin de l'objet: ...\Downloads\Commvault_Maintenance_11_28_32_WinX64\BinaryPayload\CvEdgeMonitor.exe.zip//

SHA256: A869B4A2B2559E00A2D773D7FA987AC0DBF0653506EA6667791AAC21949919F5

MD5: F0D0133E1735F5F48A9BC00CF6857403

Raison: Protection Cloud

 

Is there someone else with this problems ?


9 replies

Userlevel 5
Badge +14

Hello @SébastienV 

If the checksum doesn’t match, I would suspect something is happening to the files as its being downloaded. Since Kaspersky is already flagging files as Virus\Malware when doing the local package I would suspect it is also to blame with the download.

Can you implement our AV exclusions and see if the issue persists?

Recommended Antivirus Exclusions for Windows - https://documentation.commvault.com/11.23/expert/8665_recommended_antivirus_exclusions_for_windows.html

 

Thank you,
Collin

Userlevel 4
Badge +9

Hi @SébastienV 

 

It seems your antivirus is considering this file to be malicious, potentially because it suspects an exe within a zip to be suspicious. If this is obtained via ma.commvault.com or store.commvault.com you can rest assured this is a trusted file.

I am attempting to reproduce your download issue using the latest bootstrapper from the store, in the interim you can also try downloading the complete media kit.
https://cloud.commvault.com/webconsole/softwarestore/#!/130/729/23875

Badge +1

Hello

I tried to download from a serveur which has the commvault exclusion in place from kasperky, it is good for the virus because the files are not scan, this is a very good method for hidding a problem ^^

 

But i still have the problem :

26116 12    11/24 12:17:17 ### ### ### - Adding CVWebPatchStatus package as dependency to Commserver/WebServer for preupgrade checks during upgrade\update installation
26116 12    11/24 12:17:17 ### ### ### - Téléchargement de fichiers pour WinX64 ...
26116 11    11/24 12:17:17 ### ### ### - Download URL:[https://downloadcenter.commvault.com/CVMedia/11.0.0/BUILD80/SP28_4489590_R1081/Windows/], NumberOfDownloadStreams:[3]
26116 18    11/24 12:20:48 ### ### ### - Checksum [1362643267] of the file [D:\Sources\11.28.34\WinX64\ThirdParty\Python\x64\Lib\installpythonmodules.py] doesn't match with the expected checksum [1248360684].
26116 18    11/24 12:20:48 ### ### ### - Checksum [1362643267] of the file [D:\Sources\11.28.34\WinX64\ThirdParty\Python\x64\Lib\installpythonmodules.py] doesn't match with the expected checksum [1248360684].
26116 18    11/24 12:20:48 ### ### ### - Checksum [1362643267] of the file [D:\Sources\11.28.34\WinX64\ThirdParty\Python\x64\Lib\installpythonmodules.py] doesn't match with the expected checksum [1248360684].
26116 18    11/24 12:20:48 ### ### ### - Error: Failed to download file: [D:\Sources\11.28.34\WinX64\ThirdParty\Python\x64\Lib\installpythonmodules.py], download URL: [https://downloadcenter.commvault.com/CVMedia/11.0.0/BUILD80/SP28_4489590_R1081/Windows/ThirdParty/Python/x64/Lib/installpythonmodules.py?__cv__=1669290648_0a06ffbb472a2d3350e0916be3eaea98]
26116 12    11/24 12:21:13 ### ### ### - Error: Could not download files:

Userlevel 7
Badge +17

Are you downloading via an internet proxy?
I have seen multiple environments which are having download issues because of issues on the internet proxy.

Badge +1

i don’t use any proxy …
i download from this link to : https://cloud.commvault.com/webconsole/softwarestore/#!/130/729/23875 and tryed to upgrade but it fails with error : Error: Impossible d'installer PythonModules avec le code d'erreur  0x8007000

 

Userlevel 5
Badge +14

Hello @SébastienV 

I would suggest that if Kaspersky is generating alerts about Commvault files, then exclusions are not in place.

Can you try downloading and generating the custom package on a machine that does not have Kaspersky installed?

 

Thank you,
Collin

Badge +1

yes this is what i do this morning

 

Userlevel 6
Badge +15

hi There

Today, trying to upgrade my Commserve from v11.26.49 to v11.28.36.

Failed for 3rd part tool / python : 

304  1     12/07 10:54:12 4978408 ### ### - Succeed to launch "C:\Program Files\dotnet\dotnet.exe" "C:\ProgramData\Commvault Systems\Galaxy\Temp\CVPatchStatus\Base\CVPatchStatus.dll" Instance001 2304 80 "D:\CV"  
2304  1     12/07 10:54:12 4978408 ### ### - Timeout period 60 mins for package: Python_X64.
2304  1     12/07 10:54:12 4978408 ### ### - Started install/update of package: Python_X64...
2304  1     12/07 10:54:48 4978408 ### ### - Completed install/update of package: Python_X64
2304  1     12/07 10:54:48 4978408 ### ### - Timeout period 60 mins for package: PythonModules.
2304  1     12/07 10:54:48 4978408 ### ### - Started install/update of package: PythonModules...
2304  1     12/07 10:55:27 4978408 ### ### - Error: Failed to install PythonModules with error code 0x80070001.  
2304  1     12/07 10:55:27 4978408 ### ### - Set application exit code=[Failed]
2304  1     12/07 10:55:27 4978408 ### ### - Apply prerequisites completed ...  Status = -2147024895
2304  1     12/07 10:55:27 4978408 ### ### - Error: Installation failed. Please check the logs at [D:\CV\Log Files].
2304  1     12/07 10:55:27 4978408 ### ### - Set application exit code=[FailedInstallThirdParty]
2304  4     12/07 10:55:27 4978408 ### ### - Setup is shutting down with exit code FailedInstallThirdParty ... 
2304  4     12/07 10:55:27 4978408 ### ### - Set application exit code=[FailedInstallThirdParty]

 

Looks like I missed something.

Sources were downloaded from updates yesterday in v11.28.32, while v11.28.36 was just released today, so I initiated a new download updates+sync cache job before my attempt to upgrade.

I’m pondering on my side at the moment if I should raise a case to support or postpone my migration attempt to tomorrow, and revert to v11.28.32 instead. Also considering to download sources in parallel (but this is always way slower, as I have to re-upload them to my CS...)

 

Laurent. 

Userlevel 6
Badge +15

All right folks.

So after a quick log checks, I thought that the new FR28 included 3rd-part python binaries, and I bet that this would require a reboot of my Commserve before the setup would be able to execute the python scripts… I had no popup or clear log stating this, though… (bad point 😣...)

So, after rebooting the server and doing nothing, the setup resumed and went on fine.

Now, it’s upgrading and updating..  Phewwwww. I had serious doubts on that one.

May I suggest that such ‘reboot needed’ would generate a POPUP window or at least a BIG EMPHASIZED ENTRY in the cvupdate.log ?

Reply