Solved

SP24 - Performance & Data Readers

  • 18 August 2021
  • 7 replies
  • 1476 views

Badge +1

Has anyone experimented with the “Automatically use optimal number of data readers”?

I set this on some test SubClients and it is defaulting to 1 regardless of what the manual setting is. This results in jobs taking dramatically longer?

 

Does anyone know how the readers are optimised?

Why does it default to 1 regardless of the starting position?

icon

Best answer by MarkP 23 August 2021, 10:00

View original

7 replies

Userlevel 7
Badge +23

Hey @MarkP , thanks for the post!

Sharing the link for the feature for anyone else following along:

https://documentation.commvault.com/11.24/expert/10979_setting_data_readers_for_file_system_agents.html

  • Automatically use optimal number of data readers

    Applies to: Windows file system agent, UNIX file system agent, Laptop agent, and multi-node agents such as Network Shares, Hadoop, GPFS, GlusterFS, and LustreFS.

    When you select this option, the software automatically assigns the number of streams or readers required to perform the backup operations. The number of data readers that are assigned are based on the number of nodes configured for the subclient. This option is enabled by default.

Can you confirm how many nodes you have configured for the subclient?  I’m wondering if it is working as expected, but because you only have 1 node (and therefore, that’s the best number to use).

Badge +1

Reading the documentation and looking at my configuration the “nodes” statement makes no sense.

Where is this configured? The only place I can see is the Lustre Pseudo client where clearly there are Data Access Nodes so if it applies to this I can see some logic.

At the moment it appears that a new default configuration is effectively halving the performance. On a  Applying it by default to everything appears counter-intuitive and I struggle to see the benefit, particularly when the default is 1 compared to 2 previously.

Is this really operating as intended?

Thanks

 

Userlevel 7
Badge +23

@MarkP , I’ll see if I can get one of our folks who know Lustre to join in here.

Userlevel 4
Badge +13

@MarkP 

 

Could you select the “Allow multiple data readers within a drive or mount point” option checked under the advanced sub-client properties under the performance tab

 

Doc link click here

 

  1. From the CommCell Browser, expand Client Computers > pseudo-client > Big Data Apps > instance.

  2. Right-click the default subclient and click Properties.

    The Subclient Properties dialog box appears.

  3. Specify the basic settings for the subclient:

    1. On the Data Access Nodes tab, select the data access nodes that you want to add to the subclient, and then click Add.

    2. On the Content tab, click Browse or Add Paths to include the content that you want to back up.

      Note:

      • Subclient content paths can only be Lustre mount points. You can configure only one Lustre mount point for a subclient.

      • Nested Lustre mount points are not allowed.

  4. Click Advanced.

    The Advanced Subclient Properties dialog box appears.

  5. On the Performance tab, specify the number of data streams:

    1. In the Number of Data Readers box, enter the number of data streams.

      Tip: For optimal sharing of the backup load, the number of data readers must be equal or greater than the number of data access nodes.

    2. Select the Allow multiple data readers within a drive or mount point check box.

    3. Click OK.

Badge +1

Thanks, yes I had understood that part, I think the confusion arises because it is there as an option on Subclients that don’t support this technique. You have to delve in the documentation to find the references.

https://documentation.commvault.com/commvault/v11/article?p=62572.htm

I would suggest that the dialogue is updated to reflect the use case properly and the online documentation specifically references that the option is not valid for standard Subclients.

https://documentation.commvault.com/11.24/expert/10978_multi_stream_backup_operations.html

 

Userlevel 7
Badge +23

@Seema Ghai , can you take a look at the documentation as per @MarkP ‘s note?

Userlevel 7
Badge +23

@Seema Ghai , @Chandra tagging for documentation review.

Reply