SQL Log Files do not follow Plan settings

Userlevel 2
Badge +8

Hey all - I am working with a customer on SQL log backups.  The log RPO on the plan is 15 minutes and we verified in the Java GUI that the auto schedule is also 15 minutes.  the problem is the logs are backing up every 30 minutes and we can’t figure why.




What could I be missing?




Best answer by Mike Struening RETIRED 17 February 2022, 17:58

View original

17 replies

Userlevel 7
Badge +23

Hmmmm, definitely an interesting one.  I thought perhaps that the jobs were taking a bit longer than expected, extending the time out but that’s not the case.

What’s also interesting is that the jobs are not a straight 15 or 30 minutes apart either, though it’s awfully close to 30 minutes.

I’m going to chat with some of our SQL folks and see if they can advise here.

Userlevel 2
Badge +8

@Mike Struening  maybe I can get a stump the experts award!!!

Userlevel 6
Badge +18

I don’t know the answer, but I’m testing the 15 min config in my lab.  It’s working as expected.


Badge +15

You probably already checked, but when you double click that job, can you make sure that the schedule that is being triggered is the one you actually want (15min)?

Userlevel 2
Badge +8

@dude yep we checked through the Java GUI that the correct schedule was assigned.  That is why I have no idea what else to look at.  Everything looks fine to me from a schedule standpoint.  They do have some Dev Plans that are every 4 hours and those are running as expected.


Userlevel 7
Badge +23

@Mike Struening  maybe I can get a stump the experts award!!!

We definitely need that award, and so far you might be a contender!

@Scott Moseman , assuming yours is configured the exact same way as @Melissa Adams ‘s screenshots?

I’m hoping to get some of our support folks to take a look as well.

Badge +15

@Melissa Adams here is a test I would try.

Create a second schedule similar to the one in question and assign to one of the existing clients currently in the schedule you are showing.

Remove this client from the main schedule you are showing on the screen and see if that shows every 15 or 30?

Did you recently updated the CommCell?

Badge +15

Also, by reviewing your first screen shot, I do not see an option marked there for example Daily.

Reading the docs I see that;

Continuous: source

Runs an administration or backup job continuously. The next job session of a continuous schedule starts automatically after the previous job completes. You can define the time interval between two backup job sessions. By default, the next job session starts 30 minutes after the previous job session completes.

Badge +15

Yes, I think we are getting to the point here.


  • By default, the plan includes a continuous incremental schedule set to the RPO value for the plan.

It links to the point I mentioned above about Continuous schedules. 

Now what I would do here to just quick test is simple change from Continous to Daily and monitor for 30 mins. It should run twice.



Userlevel 2
Badge +8

@dude  This is not something I want to try.  This customer is 100% using command center and we need to focus on what the plan is doing.   I do not want to start testing things in the Java GUI.  Here is what I found on automatic. 

  • Job Interval

    Set up the job based on the log files in the destination directory.

    • Back up on file activity every

      This parameter ensures that the software does not frequently run the job. The software does not check the other options during this interval.

    • Force a backup every

      This parameter ensures that the software backs up the logs even when the other options have not been met. For example, if the parameter is set to 24 hours and the software has not run an automatic log backup in that time, the software will start a backup without checking the other options.

I’m assuming that this should be following the 15 minutes based on this unless I’m missing something or we don’t have some sort of check box checked.

Badge +15

@Melissa Adams what hotfix pack are you running.  I was just looking in to some of the most recent ones and for FR24 and saw this. I know that in your case it is SQL, but looks like to be a similar behavior.

Continuous schedule of VSA snap backup copy may not execute every 4 hours as configured 4471, 4472

See this one too, but the description is not completely clear. 

Continuous schedule may kick of jobs repeatedly for SQL subclient 3801, 3802

Maybe Mike has more info on this, but there are quite a few updates related to Continuous jobs, so would not be surprised if any of the above were to fix that. 

Userlevel 7
Badge +23

@dude , @Melissa Adams I’ll talk to some internal folks about the patch.  I’m leaning towards “Open a case” since it is working for some people, but not for Melissa (and her point about the Command Center only is valid.  Shouldn’t need to hop back and forth, though @dude ‘s test plan was good)..

Userlevel 7
Badge +23

@Melissa Adams , I heard back from the Manager of our Messaging team (they own SQL) who said this needs to be investigated by support.

Can you create an incident and share the number so I can track accordingly?

Userlevel 2
Badge +8

@Mike Struening 220106-572 is the incident.  We just opened it.

Thanks for your help on this!

Userlevel 7
Badge +23

Thanks!  You have a fantastic engineer assigned, too!

Userlevel 7
Badge +23

Sharing the case solution:

The RPO set on the plan is designed to check in the database qualifies for a new backup at that set interval.

In this case every 15 minutes it was checking if the log file is 80% utilized as the settings are configured.
- As the log was not 80% utilized it would then skip the 15 RPO backup

It was also set to force a backup every 15 minutes. This was not running every 15 minutes because it calculates the end time of the last job.

15 minutes from the start time of the previous job it checks if it qualifies for a backup.
- As explained above it skips the normal RPO backup because the log is not 80% utalized.
- It also skips the force backup because it has only been about 8-12 minutes since the END time of the last job. As it has not been 15 minutes it then skips the force job.

15 minutes later (30 minutes from the start time of the last job) it does the same check again.
- Either the log file is now 80% utilized or its over 15 minutes from the end time of the last job, so the job then runs again.

Customer reverted to a Daily schedule setting to repeat every 15 minutes as a workaround to get more consistent backups every 15 minutes


Hi Guys, I am having the same issue. How did you fix it?