Solved

AuxCopy between 2 HPE StoreOnce Catalyst


Badge +2

We have 2 data centers, each having a HPE StoreOnce Catalyst Appliance and configured to a media agent in the data center.

DC1- dc1mediaagent <> DC1 HPE Store

DC2-dc2mediaagent ↔️ DC2 HPE Store

Now we want to get an AuxCopy going between DC1-HPE Store to DC2-HPE Store and another DC2-HPE store to DC1-HPE Store.

 

We have tried configuring the libraries and sharing them to the other media agent.  but the AuxCopy fails with Chunk errors   Failures constantly

We had no issues using Synology arrays between DC1 and DC2.

Any ideas on best practice with HPE StoreOnce appliances?

 

Thanks

Larry

icon

Best answer by Mike Struening 25 January 2022, 22:14

View original

10 replies

Userlevel 7
Badge +23

Hi Larry, thanks for the post!

We’ll definitely need to dive into the errors and logs to see what’s going on.  Chunk errors in themselves don’t tell us much, though the contextual message about the error will guide us.  Anything else at this point would be pure speculation.

Check AuxCopyMgr.log and CVMA.log (on the Media Agent for the latter) for the time frame you received the error and we can see what’s going on.

Thanks!

 

Badge +2

Hi Mike,  We have deleted all the storage policies and library setup for the Auxcopy.  I do not see the errors in the logs.  is AuxCopy the best tool to do the replication?

 

I am looking for anyone with documentation relating to best practice replicating from one Data Center HPE StoreOnce to another Data Center HPE StoreOnce.

There might be something we are missing from the Commvault documentation that someone might know about.

Userlevel 2
Badge +3

https://documentation.commvault.com/11.24/expert/102417_configuring_auxiliary_copy_on_hpe_catalyst_library.html

The destination MA must be shared with the source library/mount paths.

Also both must be the same protocol (FC or IP, can’t mix).

Both storeonce need communication to each other since when we aux copy StoreOnce->StoreOnce we call the Catalyst Copy function of the devices and they do the direct copy themselves.

Now the above doesn’t apply if you are simply using CIFS exported from the StoreOnce. That’s just a normal aux copy in CV then.

Badge +2

I tink my problem is the storage admin setup the libraries as iSCSI connects to the media agents.

This works fine for client backups, but seems to be a problem going from one DC! media agent to DC2 media agent and visa-versa.

Larry

Userlevel 2
Badge +3

I don’t see why that wouldn’t work. We would need to do a log review. Can you create a case, classify it as Aux copy, and someone will look into it?

Userlevel 7
Badge +23

@lgriswold , once you create the case, share the case number so I can follow up accordingly.

Badge +2

Mike we have recreated the auxcopy policy and are getting the chunk errors.  Seems the secondary is offline to the primary

 

I created a case

Incident Number 211214-480 Has Been Successfully Created.

 

Larry

Userlevel 7
Badge +23

Thanks!  Looks like you were automatically sent some Solution Content.  Be sure to review and mark it as helpful (closes case) or not helpful (routes to an engineer).

Badge +2

I have responded to the helpful hints..  Support is looking at it.  they say the share is not accessible.

 

I did what the doc says about having to share copy library with primary media agent.

 

Userlevel 7
Badge +23

Sharing case resolution:

- The customer has copy <Oracle SP name> / Copy-1.
- The copy is going into pending due to <server name> not having any information for MP ID:32 in its registry.
- Upon checking the configuration, we could see dc1cmmedia1 has been configured to access the source library but the accessibility is showing as NO.
- The customer confirmed the MA does not have access to the source library as its on a different site.
- The configuration was removed and a new job was ran but the same issue occurred.
- We restarted the services on MA but we continue to see the same issue.
- We have rebooted the OS on <server> and <CS name>but the issue is still the same.
- We would like to understand why <server name> is throwing errors for MP ID 32 access when it is no longer configured to have access.

https://documentation.commvault.com/11.24/expert/102417_configuring_auxiliary_copy_on_hpe_catalyst_library.html

Solution:

Src and Destination are HPE Catalyst Libraries. In this case, the config needs to provide access of the Src Mount Path to the Destination MA also. And the sharing should be using the Same Protocol.

Reply