Failed to install Base Package

Userlevel 2
Badge +6

Hi all,

Can someone help me with this error:

Failed to install Base Package. Failed to access remote registrySource: commvault, Process: DistributeSoftware

Error code was 68:182

I want to install CV agent on new Windows server 2019  from our CV console. I read that I need to allow WMI users right access (its standard Admin user account with full rights), even I added our domain admin on WMI access list - SAME ERROR

Then I read I need to start Remote Registry service  - its started and SAME ERROR

Then I disabled Firewall and that machine - SAME ERROR

What can be a problem?




Best answer by Peanut 18 June 2021, 18:37

View original

21 replies


Is there a firewall between the CommServe and the Client?

Here is a list of Prerequisites:

on Windows computers, do the following:

  • Open Port 135 for DCOM (Distributed Component Model).

  • Open Port 139 for NetBIOS Session Service (if you are using legacy Windows computers, such as Windows NT or earlier versions).

  • Open Port 445 for SMB (Server Message Block) file sharing.

  • Open the Windows Management Instrumentation (WMI) port. For instructions on setting up a fixed port for WMI, see Setting Up a Fixed Port for WMI on the Microsoft website.

Userlevel 2
Badge +6

Hi @LouZ ,

CommCell and that machine are in the same domain (different subnet) but in the same domain, and not go trough proxy server. 

Thank you for fast reply. I though that CV installation will do that job on Firewall (worked without problem before Windows Server 2019). When I turn Firewall on that new server OFF, why need to open those ports?

BTW, we are on 11.21.34 version.

Userlevel 7
Badge +15

edit: @Edwin McLaughlin has a great tip to troubleshoot this!

Note that the installer cannot make adjustments to the firewall if the connection to the client is failing. If you install interactively, it can disable the firewall, but remotely if the firewall is preventing the connection, it cannot be turned off.

Badge +3

Hello @Vladan Kojanic,

As the remote installation is reporting a failure to connect to the remote registry of the intended client, you should first check that the remote registry of the client is reachable from the CommServe computer. You can test this with the following steps performed on the CommServe:

  1. Open Registry Editor by executing regedit from any command line interface in Windows, like Command Prompt or the Run dialog box.
  1. Go to File > Connect Network Registry.
  1. Type into the large empty space the name of the computer you want to remotely access the registry for.
  1. Select “Check Names” which will populate the remote client’s full path
  1. Choose OK.

After a few seconds, RegEdit will connect to the remote computer's registry and you should see the client’s registry under [hostname]. If this fails, there may be some additional firewall software on the client blocking the connection.

Userlevel 2
Badge +6

Hello @LouZ , all,

I disable all Firewalls on server that I want to install CV, but remote install fail again.

I did what @Edwin McLaughlin suggested (from CV server) and I do see remote registry (selected):


Userlevel 7
Badge +23

@Vladan Kojanic , what do you see in distributesoftware.log at the time of the failure?

Userlevel 2
Badge +5

@Vladan Kojanic sounds like WMI failure if remote registry is enabled. You might try the following to validate its passing these requests off properly.


How to troubleshoot WMI Connection or Access Denied or Network Path Not Found:

"wbemtest" can be run on the CommServe from a Command Window:

Type wbemtest on the command prompt of the CommServe and click the Connect button

In the Namespace filed type- \IP Address of the Target Machine\root\default

Input the credentials being used by Commvault for the installation attempt on this target machine and then click Connect

If wbemtest can connect, then you should be returned to the first page and will be connected. Otherwise an error will occur. As wbemtest is a Microsoft application, this demonstrates that the issue is most likely the configuration on the target machine.

To test WMI from command line:

C:\> wmic /node:[targetIPaddr] /user:[admin] process call create "cmd.exe /c [command]"


wmic /node:(IP Address) /user:domain\user process call create "calc.exe"
wmic /node:(IP Address) /user:domain\user process call create "cmd /c Echo This is my WMI Test %Date% %Time% > C:\WMITest.txt"

Userlevel 2
Badge +6

@Vladan Kojanic , what do you see in distributesoftware.log at the time of the failure?

Mike, here is output from log file:

11752 1bdc  06/18 14:55:32 1151675 Packages selected For Install :File System Core,File System

11752 1bdc  06/18 14:55:32 1151675 CommServe Cache Location [E:\SWCache]

11752 1bdc  06/18 14:55:33 1151675 GetIsUsingNewDownload() - Use New Download key is set to [true]

11752 1bdc  06/18 14:55:33 1151675 [SetCSCacheInfo]() - Trying to move to side by side cache.

11752 1bdc  06/18 14:55:33 1151675 [TransitToNewDownload]() - Staging folder [E:\SWCache\CVMedia-Staging\11.0.0\Windows] does not exist, checking regular cache

11752 1bdc  06/18 14:55:33 1151675 [TransitToNewDownload]() - Regular cache [E:\SWCache\CVMedia\11.0.0\Windows] is also empty, skipping the transition.

11752 1bdc  06/18 14:55:33 1151675 [SetCSCacheInfo]() - Do not need to do clean up or baseline update.

11752 1bdc  06/18 14:55:33 1151675 [getThreadPoolCount] Initializing thread pool size : 5

11752 1bdc  06/18 14:55:33 1151675 Thread pool monitor interval [300] seconds, Refresh interval [60] seconds

11752 1bdc  06/18 14:55:33 1151675 [ComputeRequiredRelAndOsList]() - Could not get answer file since install directory is empty for client [Finansije].

11752 1bdc  06/18 14:55:33 1151675 [ComputeRequiredRelAndOsList]() - Successfully launched thread with Id [1] for [Finansije] to get it's binaryset name.

11752 1bdc  06/18 14:55:33 1151675 [ComputeRequiredRelAndOsList]() - Waiting for all the clients threads to complete..

11752 14ec  06/18 14:55:38 1151675 CVImpersonateLoggedOnUser() - caching user sid [S-1-5-18] for optimizing subsequent impersonate operations for this user

11752 14ec  06/18 14:56:21 1151675 [GetClientOSType]() - Failed to compute the binary set name of client [].

11752 14ec  06/18 14:56:21 1151675 [GetClientOSType]() - No remote cache is associated with client, Setting error status for client [648]

11752 14ec  06/18 14:56:21 1151675 [fnCSUpdateDBJMStatusNew]() - Client status [ QINSTALL_ERROR_ACCESS_REMOTE_REG] set successfully in JMQinetixUpdateStatus Table  for client [ 648] [  ]

11752 1bdc  06/18 14:56:21 1151675 [CheckAndDownloadRequiredMedia]() - Download is not required.

11752 1bdc  06/18 14:56:21 1151675 [ReadPackageDetails] Packages.xml location E:\SWCache\CVMedia\11.0.0\SP21_2957659_R830\Windows\WinPackages.xml

11752 1bdc  06/18 14:56:21 1151675 [getXMLDetails]() - Get XML details from [E:\SWCache\CVMedia\11.0.0\SP21_2957659_R830\Windows\WinPackages.xml] with input: [E:\SWCache\CVMedia\11.0.0\SP21_2957659_R830\Windows\WinPackages.xml] isBinaryXML [no]

11752 1bdc  06/18 14:56:21 1151675 [getXMLDetails]() - Get XML details from [E:\SWCache\CVMedia\11.0.0\SP21_2957659_R830\Windows\BinaryInfo.xml] with input: [E:\SWCache\CVMedia\11.0.0\SP21_2957659_R830\Windows\] isBinaryXML [yes]

11752 1bdc  06/18 14:56:23 1151675 [SetSidesToBeInstalledOnRCClients]() - Number of software caches involved in this job are [1]

11752 1bdc  06/18 14:56:23 1151675 Only remote cache's having status as invalid will be tried for sync.

11752 1bdc  06/18 14:56:23 1151675 [SyncUAForJob]() - Remote cache list is empty for the syncup.

11752 1bdc  06/18 14:56:23 1151675 Number of clients in job: [1]

11752 1bdc  06/18 14:56:23 1151675 [CheckIfOperationNeededForClients]() - Client Finansije status is not set to to be done. Skipping this client in this run..

11752 1bdc  06/18 14:56:23 1151675 

11752 1bdc  06/18 14:56:23 1151675 ******   Now Check status of all clients   ******

11752 1bdc  06/18 14:56:23 1151675 Waiting for the remote cache syncup threads to be completed..

11752 1bdc  06/18 14:56:23 1151675 Clients Pending:

11752 1bdc  06/18 14:56:23 1151675 Client [648] [Finansije] [QINSTALL_ERROR_ACCESS_REMOTE_REG]

11752 1bdc  06/18 14:56:23 1151675 *******************************************

11752 1bdc  06/18 14:56:23 1151675 bvSuccess = false, bvFailed = false, bvRestartNeeded = true, bvUnknown = false, bvOperationNotSupported = false, bvSkipped = false, bvPartialSuccess = false, bvMachineRebootRequired = false m_nvJobRetStatus = 6

11752 1bdc  06/18 14:56:23 1151675 Job will be restarted by JobManager (failed).

11752 1bdc  06/18 14:56:23 1151675 COMPLETE CALLED (PHASE Status::FAIL), Job ID = 1151675

11752 a7c   06/18 14:56:23 1151675 CVJobCtrlLog::unregisterProcess(): successfully removed file [C:\Program Files\Commvault\ContentStore\Base\JobControl\11.752]


Userlevel 2
Badge +6

@Vladan Kojanic sounds like WMI failure if remote registry is enabled. You might try the following to validate its passing these requests off properly.


I got this: ERROR:
Description = The RPC server is unavailable.

I did check and all services are ON on that target server. I also check the Firewall and its OFF. Seams Windows server 2019 have some other issue regarding RPC connectivity

Userlevel 7
Badge +23

I’ll defer to @Stogs if he has any thoughts, though I would suggest opening a case with Customer Support (and sending me the case number).  The logs point to the remote registry access being the issue, yet you confirmed it works...definitely a puzzler.

Userlevel 5
Badge +10

Not sure we can do much here. That RPC error points to an environmental issue, not CommVault software

Error the RPC server is unavailable - Windows Server | Microsoft Docs


@Vladan Kojanic 


  There may be security policies in place that are not allowing access further down the registry.  I have seen many customers who have group policy in place to block access to certain registry keys.  I tested this on my own machine and attached to the registry of one of my colleagues PC’s.  I can see HKEY_LOCAL_MACHINE however I can not expand out to where I would need to write the registry.  Make sure you can expand the key and see the software key and if access further down is available.



Userlevel 2
Badge +6

I do not what’s happened, but yesterday I did manage to install CV on this new server. I did change IP address of that server (have two NIC) so I 1st time I try to one, yesterday I try to second one and it work.

Now we do have another error, when want to start backup.

  • File system: I manage to browse what I want to backup (system state) and when start backup I got error: Failed to initialize Backup request. Please check JobManager.log for more information (I look into it, but there is noting connected with this server)
  • Sql Server: With no defined SQL Agent authentication I do see databases (Autodiscover) but backup say: Description: Failed to validate the credentials for instance [servername]. Please make sure the provided user [system] has the sysadmin role. Source: servername, Process: SQLiDA. We do have backup user on that MS SQL server (with proper user rights), when I put that user in SQL Agent authentication I can see databases, but have the same error when backup start: Description: Failed to validate the credentials for instance [servername]. Please make sure the provided user [system] has the sysadmin role. Source: Servername, Process: SQLiDA

Seems we do need to open a ticket for this.

Userlevel 7
Badge +23

@Vladan Kojanic , sounds wise at this point.  Let me know the case number so I can track accordingly.

Userlevel 7
Badge +23

Hey @Vladan Kojanic , following up to see if you had a case number to share.



Hi all,
in our case, a wrong username/password results in this error message… :face_palm_tone1:



Badge +3

Hi All,

I am using the commvault tool first time and I have added my window machine in commcell, now I am going to install the agent on that machine but getting the below error,


Failed to install Base Package. Failed to access the remote registry. 

I am using Windows 10 OS there is no AD this system on the workgroup network and the machine was on the Azure portal.

username is: workgroup\commvault


For more information please find the screenshot

Also how I can download agent software from commcell and install it manually on window and Linux machine

Userlevel 7
Badge +23

Looks like you already created a separate thread:

Will follow up there.

Badge +3

yes, but I have not gotten any response on that thread so that’s why I have created a new one.


Userlevel 7
Badge +23

Makes sense.  Generally, I recommend creating a new post and linking an older one.  It helps connect the issues, and it';s much easier to track a new thread than an older (solved) one. I want to be sure that you get all of the attention you need!

Badge +3

I have already reply on that thread but still not getting any reply.