Solved

Unable to install Commvault client on SAP HANA server SLES SP12 SP4

  • 14 November 2021
  • 10 replies
  • 168 views

Badge +5

Hi,

 

Having issues with installing the Commvault client on a linux machine SLES 12 SP4 with SAP HANA.

 

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Machine : jg-sapbckupprd
File    : AutoInstall.log
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

4108  11e0  11/14 15:02:57 1315826 [fnCvUpdateDBJMStatusNew] Updating Database with evMsgId [1140850840] for  JobId [1315826], JobType [3],clientName [jg-hanadr], clientId [0]
4108  11e0  11/14 15:02:57 ####### [SendDisConnectReq]() - Sending disconnect request.
4108  11e0  11/14 15:02:57 1315826 [InstallUnixSeed]() - Before installing seed package, need to check if packages [] selected for install are supported on remote client [jg-hanadr.jaidah.local]
4108  11e0  11/14 15:02:58 1315826 [InstallUnixSeed] Base package will be installed on client [ jg-hanadr.jaidah.local ], installDirectory [  ],ans file [C:\Program Files\CommVault\Simpana\Deployment\Install\jg-hanadr.base.xml].Transferring Base package files to the client..
4108  11e0  11/14 15:03:06 1315826 [InstallUnixSeed] STDERR[]
4108  11e0  11/14 15:03:06 1315826 [InstallUnixSeed] STDOUT[1][Running remote command [id] ...
uid=0(root) gid=0(root) groups=0(root)
>>>Step 01 of 06 - identify remote user privilege
|/root|
User root's home directory is /root
User is root.
>>>Step 02 of 06 - prepare remote seeding environment
Unix Install Directory = /opt
Unix Seed Directory = /opt/seed
Running remote command [mkdir -m 777 -p /opt/seed] ...
OEMInfo.xml not found at C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\
PushFiles [detect cvpkgadd silent_install pkg.xml pkg.xml.description version] to [/opt/seed] ...
Change directory to [C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\]...
Fatal: Received unexpected end-of-file from server
*** UNIX SEEDING SETUP_ERROR 1140850872 detected and returned. ***
]
4108  11e0  11/14 15:03:06 1315826 [InstallUnixSeed] ERROR: Unix Seed Install Failed
4108  11e0  11/14 15:03:06 1315826 [InstallUnixSeed] Updating the JM status as FS core package install failed.
4108  11e0  11/14 15:03:06 1315826 [fnCvUpdateDBJMStatusNew] Updating Database with evMsgId [1140850872] for  JobId [1315826], JobType [3],clientName [jg-hanadr], clientId [0]
4108  11e0  11/14 15:03:06 ####### [SendDisConnectReq]() - Sending disconnect request.
4108  2350  11/14 15:16:41 ####### LocalAUJobReqHandler Received Request to SeedUnixClient

 

 

Please advise.

icon

Best answer by ElmerT 20 November 2021, 16:52

View original

10 replies

Userlevel 6
Badge +13

 

“Fatal: Received unexpected end-of-file from server” 

“C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\OEMInfo.xml ”

2 tips:

  • retry the installation in case of network hiccup.
  • Clear the software cache, and download it again.

check if this file exists on the CS: “C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\OEMInfo.xml”

Badge +5

Hi @Bart ,

 

Thanks for the tips. Already done these but still no success.

 

Regards,

Userlevel 7
Badge +23

Hi @ElmerT !

I found a single case in our database with the same error.

Here’s the solution:

- Disabled remote cache on the Hyperscale Appliance. - Renamed software cache to _old. - Initiated a new download software of just Windows x64 which completed successfully. - Advised customer to now download Linux package and perform a remote cache sync which both completed successfully. - Kernel update was performed and completed and I was advised the case could be closed.

Let me know if that helps!

Badge +5

Tried to rerun the software installation after removing the server  from the client computers. However still getting installation failed. I have attached here the job log.

 

Regards,

Userlevel 7
Badge +23

Thanks, @ElmerT !

Seeing some odd logging here (below).

The issues in our database for this message generally involve repopulating the software cache which you have done.

I did find one more option to look into:

Customer found that client server did not have forward DNS entry configured for communications to commserve.

Other than that, I would suggest creating a support case (and sharing the case number here).

File    : DistributeSoftware.log
16468 2bf0  11/17 17:27:55 1316415 GetRemoteProcessorType() - Couldn't transfer file [C:\Program Files\CommVault\Simpana\Base\detect] to the remote machine [/opt/seed/detect] with error code [1] and error string [].16468 2bf0  11/17 17:27:55 1316415 [GetClientOSType]() - Failed to compute the binary set name of client [<client name>].16468 28b0  11/17 17:27:55 1316415 [CheckAndDownloadRequiredMedia]() - Download is not required.16468 28b0  11/17 17:27:55 1316415 [ReadPackageDetails] Packages.xml location C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\pkg.xml16468 28b0  11/17 17:27:55 1316415 [getXMLDetails]() - Get XML details from [C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\pkg.xml] with input: [C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\pkg.xml] isBinaryXML [NO]16468 28b0  11/17 17:27:55 1316415 [ReadPackageDetails] Get XML details returns [true], osId [-1] and file path [C:\Program Files\CommVault\Simpana\SoftwareCache\CVMedia\11.0.0\SP16_2046897_R645\Unix\pkg.xml], isWindows [false]16468 28b0  11/17 17:27:55 1316415 Only remote cache's having status as invalid will be tried for sync.16468 28b0  11/17 17:27:55 1316415 [SyncUAForJob]() - Remote cache list is empty for the syncup.16468 28b0  11/17 17:27:55 1316415 Number of clients in job: [1]16468 28b0  11/17 17:27:55 1316415 Created lock file [C:\Program Files\CommVault\Simpana\Deployment\SwCacheLocks\jg-sapbckupprd\ReadLocks\P16468_J1316415.lock]16468 28b0  11/17 17:27:56 1316415 Rights for user <your email address>(4) are OK16468 28b0  11/17 17:27:56 1316415 Use updated binary set id [0] for client id [-1]16468 28b0  11/17 17:27:56 1316415 [GetClientInfo]() - Unsupported OS Type 0 for client Id -116468 28b0  11/17 17:27:56 1316415 [CheckIfClientPlatformIsDeprecated]() - Unable to get client information. Ignoring client platform deprecation check16468 28b0  11/17 17:27:56 1316415 [CheckIfInstallRequired]() - Ports numbers are not specified from GUI. checking Whether the machine is already part of CS16468 28b0  11/17 17:27:56 1316415 CheckWhetherClientIsAlreadyPartOfCS() - No Client found with the host name <client name> and with the CS release and build number. Install Base..16468 28b0  11/17 17:27:56 1316415 [CheckIfInstallRequired]() - It is a pre install. New client will be installed..16468 28b0  11/17 17:27:56 131641516468 28b0  11/17 17:27:56 1316415  ******	New Client = [jg-hanadr], ClientId = [-1], Release = [11.0.0], UpdateAgentClientId = [2]16468 28b0  11/17 17:27:56 1316415 Client [jg-hanadr] cache source : CommServe16468 28b0  11/17 17:27:56 1316415 No package or update requires reboot as per info on CS, client can reboot (if required) during actual installation16468 28b0  11/17 17:27:56 1316415 [ComputePatches]() - Client [<client name>] does not have valid OS id
Badge +5

Hi @Mike Struening I opened a case with Fujitsu. Fujitsu ref FS-5161919.

Thanks.

 

Userlevel 7
Badge +23

Thanks, @ElmerT !

If it gets escalated to Commvault support, let me know!

Badge +5

Hi @Mike Struening 

I was able to install the Commvault agent locally. I can see now the client in the Commcell console. Unfortunately Discover Database is not showing so have to work on that.

Thanks for the support.

 

Userlevel 7
Badge +23

@ElmerT , keep us posted on the discover issue (and if we can help, just ask)!

Badge +5

HI @Mike Struening . I already fixed that. Thanks!

Reply