Solved

/webconsole/api/v2/MediaAgents status and offlineReason codes

  • 18 August 2023
  • 4 replies
  • 100 views

Badge +4

The GET V2 MediaAgents API has some numeral codes for offlineReason and Status which seem to reflect some different senarios.  I have seen 0, 1, 2, and 5.  Usually there is documentation coving these things but I not finding it in the online documentation.  Do we have a link to this info?

{

            "offlineReason": 0,

            "description": "",

            "status": 1,

            "mediaAgent": {

                "mediaAgentId": 2,

                "_type_": 11,

                "displayName": "dm2perf3",

                "mediaAgentName": "dm2perf3"

            },

            "osInfo": {

                "osId": 210,

                "OsDisplayInfo": {

                    "OSName": "Windows Server 2016 Datacenter"

                }

            },

            "versionInfo": {

                "UpdateStatus": 0,

                "GalaxyBuildNumber": "11",

                "GalaxyRelease": {

                    "ReleaseString": "11 SP17",

                    "_type_": 58,

                    "ReleaseID": 16

                }

            },

            "mediaAgentProps": {

                "pushMA": false,

                "isPreConfigured": false,

                "isUnlicensedMA": false,

                "isVirtualsClient": false

            },

            "powerManagementInfo": {

                "isPowerMgmtAllowedCheck": true,

                "isPowerMgmtSupported": false

            }

        }

                "mediaAgentName": "yashdutch"

            },

            "osInfo": {

                "osId": 210,

                "OsDisplayInfo": {

                    "OSName": "Windows Server 2012 R2 Datacenter"

                }

            }

icon

Best answer by G2T 21 August 2023, 20:43

View original

4 replies

Badge +4

Commvault provided via iternal documentation.

Please find the MA offline reasons below, and description of the error accordingly 

==

HOST_STATUS_DEFAULT = 0  No errors detected

HOST_STATUS_CONNECT_FAIL = 1 Cannot communicate with Media Mount Manager Service/ Please ensure that / The MediaAgent is reachable from CommServa and All MediaAgent services are running.

HOST_STATUS_VERSION_MISMATCH = 2 The CommServe and MediaAgent versions appear to be different. They must be the same. Please upgrade your MediaAgent.

HOST_STATUS_MARKED_DISABLED = 3   The MediaAgent has been marked as disabled.

HOST_STATUS_OLDER_VERSION_AND_PAST_GRACEPERIOD = 4  MediaAgent has been marked disabled as it has exceeded the pre-determined number of days since the CommCell has been upgraded.

HOST_STATUS_INITIALIZING = 5  The MediaAgent is initializing and refreshing the device information.

HOST_STATUS_MIGRATED = 6  The MediaAgent has been migrated to different CommServe.

HOST_STATUS_POWER_MANAGED_VM = 7  This Media Agent is powered off by Power Management.

HOST_STATUS_NODE_REFRESH_ERROR = 8  Media Agent marked offline as node refresh failed, please check logs and retry the operation

HOST_STATUS_SMART_STATE_MANAGEMENT = 9  MediaAgent is marked offline by the automated MediaAgent state management feature.

HOST_STATUS_CVFWD_DETECTED_OFFLINE = 10  Cannot communicate with Media Mount Manager Service./ Please ensure that  The MediaAgent is reachable from CommServe. and  All MediaAgent services are running.

Userlevel 3
Badge +6

@G2T where did you find/get this information?

 

Please share the link to where this is documented. Thanks!

Badge +4

Commvault support.  As far as I can tell, this info is not currently available in any public location.

Userlevel 3
Badge +6

I requested above to be documented.

Reply