“access denied” when attempting to add aws s3 to Storage Cloud library

  • 12 March 2021
  • 1 reply
  • 503 views

Userlevel 2
Badge +8

Yes the thread has been super helpful for me.  Cant thank eveyone enough for everyone sharing the commvault knowledge.

 

This question - Im not sure if its a AWS question or commvault.   
We wanted to add a AWS S3 bucket as our Storage Cloud library.  In doing so we kept on getting “access denied”  when attempting to add the aws s3.  The way we were finally able to add our S3 bucket to our commvault commserve environment as a cloud library was to DISABLE the AWS S3 bucket encryption option.  We used the AWS IAM ROLE Policy to add the S3 bucket.   Does anyone know why we cant have the encryption on the AWS s3 bucket enabled.  I feel like we should have the encytpion enabled but of course it didnt work when adding the S3.

 

Thanks again  -  BC


1 reply

Userlevel 7
Badge +23

Yes the thread has been super helpful for me.  Cant thank eveyone enough for everyone sharing the commvault knowledge.

 

This question - Im not sure if its a AWS question or commvault.   
We wanted to add a AWS S3 bucket as our Storage Cloud library.  In doing so we kept on getting “access denied”  when attempting to add the aws s3.  The way we were finally able to add our S3 bucket to our commvault commserve environment as a cloud library was to DISABLE the AWS S3 bucket encryption option.  We used the AWS IAM ROLE Policy to add the S3 bucket.   Does anyone know why we cant have the encryption on the AWS s3 bucket enabled.  I feel like we should have the encytpion enabled but of course it didnt work when adding the S3.

 

Thanks again  -  BC

I’m not too familiar with this, but previous cases suggest that you need to enable this additional setting to work with bucket encryption; specifically with managed keys.

https://documentation.commvault.com/commvault/v11_sp20/article?p=9263.htm

I am assuming setting it to 1 will resolve the issue unless you are using KMS keys, in which case set to 2 and provide the key using the other additional setting listed.

 

Reply