Solved

Command Center - restore agents

  • 15 February 2021
  • 16 replies
  • 557 views

Userlevel 6
Badge +13

Hi,

 

For some environments, we use a VM based backup.For restoring purposes, we have restore agents installed on the vms, so that individual files can be restored.

Works fine. Now the ‘problem’: when you use the command center, you can go to protection → file servers.

Because we only use the agent as restore again (no backup license active), you can see the machines over there. BUT…on that page, they all show are “red - missed” sla….panic...

Is there a way to “map” those machines to the vm , so that user doesn’t panic. 
Of course, not sure if you experience the same.

 

 

icon

Best answer by Bart 17 March 2021, 20:55

View original

16 replies

Badge +15

I`m not quite sure this is possible since the reason for the red icon represents that the vm has not had a backup in 14 days or more. In my mind the way to get that as green is really to use Commvault to actually backup the VM which is not your case.

 

Protected: When red, it indicates that the data in the client has not been backed for more than 14 days. When yellow, it indicates that the data has not been backed up in the past 7 days. When green, it indicates that recent backup operations have been performed on the computer.

https://documentation.commvault.com/commvault/v11_sp20/article?p=4533.htm

 

Userlevel 7
Badge +19

@Bart Which version are you on currently? Your situation is similar to an environment that we manage and we see exactly the same thing there as well and it is a bit annoying indeed. The reason that it displays it is because it is just using a check readiness in the background and I suspect it to be red because you have not assigned the client to a plan or a legacy storage policy.

Now I do not know exactly know what the vision of Commvault is on this part but I think many VSA driven customers leverage the agent for FLR recovery because agentless recovery is/was slow and or comes with specific requirements depending on your environment. Additionally there is currently also a link between VSA and File server when it comes to SLA which sometimes also results in an unexpected status. 

What version are you running b.t.w. because FR22 introduce improved offline client tracker functionality but it uses the Servers section in Command Center to display the client status. This should just be a regular heartbeat alike functionality that represents the communication between the client and the CommCell. 

From the bigger point of view I understand and acknowledge where you are running into and I hope we can point Commvault in the right direction to make it more logical. 

 

 

Userlevel 6
Badge +13

I’m on version 11.21.

Even after X amount of days, it remains red.
The VM backup itself is fine, you can see that on the virtualization page: 

 

 

Userlevel 7
Badge +19

Is the FS client configured with a plan or storage policy? 

Userlevel 6
Badge +13

Is the FS client configured with a plan or storage policy? 

 

The client backups are fully working with plan. So they are using plans. (a plan is also a storage policy of course ;) )

 

Userlevel 7
Badge +23

Hey @Bart !  Interesting situation here, and I assume the above comments are right on the money.

Let me ask around and see if there are any options for you to ‘clean up’ the view.

Userlevel 7
Badge +19

@Bart to be clear you are stating that you see this in case when it is a restore-only client right? so in that case you are not creating any backups using the FS but you are creating backups using VSA. now it would help if you can expand the screenshot a little bit more. 

Just checked our environment and we see the same strangeness as well see below
 

The upper one and the lower one are running the same version. The one marked red gives back "Not Available”. I cannot find a difference between them so it is very inconsistent. Both also give a status ok when doing a check readiness and it doesn't have an effect on the stoplight. So I would propose to open a ticket for it!

B.t.w. off-topic but I also noticed you cannot restart services of a restore-only client via both the CommCell console nor Command Center. It is being looked at already. 

Userlevel 6
Badge +13

I have exactly the same inconsistent behaviour. Some show as green,some show as red  .

I don't think I'll open a ticket for it. We have too many tickets open already which always causes lot of work. (Remote sessions, sending the databases, logs,etc).

Maybe I'll do it later and I'll refer to this discussion

 

 

Userlevel 7
Badge +19

@Bart we just upgraded to FR22 but I didn't had time to go over this issue once more. did you already looked into it? 

Userlevel 7
Badge +23

@Bart , following up on older threads; let me know if this is something you got an answer for.

Userlevel 6
Badge +13

I will still need to open a ticket for this.

Userlevel 7
Badge +23

I will still need to open a ticket for this.

I wonder if this is somehow related to the other incident you have (addressed in 11.23)….keep us posted. my friend!

Userlevel 6
Badge +13

I will still need to open a ticket for this.

I wonder if this is somehow related to the other incident you have (addressed in 11.23)….keep us posted. my friend!

 

I don’t think so. As the previous issue started in FR 11.22, while the other issue already existed in FR 11.21.
But I won’t open a ticket for this tho, because it’s indeed possible that this was also resolved .
ll check it again if this is resolved with the fix for the other issue, avoiding double work for everyone. 
So I’ll update this post in case the issue still exists with the other fix.

Userlevel 7
Badge +23

Appreciate that, @Bart !

Userlevel 6
Badge +13

The funny part...the fix from:

 

Seems to have resolved this issue. (FR 22) :) (but not the issue itself from that ticket :grinning: )
Diag 2302 for FR22, and should be part of FR23 already. (FR23 I cannot confirm myself, but should be OK)

 

 

Userlevel 7
Badge +23

GREEN!!  Well, I can’t say I fully expected it, but can’t say I am surprised, either!

Thanks for sharing, @Bart !  I’ll keep watching the other thread.

Reply