Solved

Commvault Agent Installation Error on Windows 10 OS

  • 23 August 2021
  • 4 replies
  • 1632 views

Userlevel 1
Badge +2

Getting below error during the commvault agent installation. 

Windows 10 OS. 

 

 

14068 4     08/23 19:19:48 ### ### ### - ------------------------ Creating New Instance ----------------------------
14068 4     08/23 19:19:48 ### ### ### - Showing dialog : PreInstallValidatonViewModel .......
14068 11    08/23 19:19:48 ### ### ### - Space Recommended for Features [390424714], Third Party Packages [0], Package Cache [195212357]
14068 11    08/23 19:19:48 ### ### ### - Total Space recommended [585637071], free space [391519252480] available on drive [C:\]
14068 4     08/23 19:19:48 ### ### ### - Showing dialog : ShutdownViewModel .......
14068 11    08/23 19:19:48 ### ### ### - Error: Failed to ServiceQuery with error :
14068 11    08/23 19:19:48 ### ### ### - Stopped all Commvault services.
14068 11    08/23 19:19:48 ### ### ### - Killing all running processes from install directory ...
14068 4     08/23 19:19:54 ### ### ### - Showing dialog : InstallProgressForPrerequisitesViewModel .......
14068 4     08/23 19:19:54 ### ### ### - Removing VCRedist_2017_win32 as it is not applicable for this OS.
14068 1     08/23 19:19:54 ### ### ### - Checking if required third-party packages are installed...
14068 1     08/23 19:19:55 ### ### ### - Installing required third-party packages...
14068 1     08/23 19:19:55 ### ### ### - Apply prerequisites completed ...  Status = 0
14068 1     08/23 19:19:55 ### ### ### - Third-party package installation completed.
14068 4     08/23 19:19:55 ### ### ### - Showing dialog : InstallProgressForPackagesViewModel .......
14068 1     08/23 19:19:55 ### ### ### - Installing packages...
14068 1     08/23 19:20:23 ### ### ### - Checking and removing stale MSI with product [File System Core]
14068 1     08/23 19:20:23 ### ### ### - Started install/update of package: WindowsFileSystemiDataAgentCore...
14068 1     08/23 19:20:56 ### ### ### - Checking and removing stale MSI with product [File System]
14068 1     08/23 19:20:56 ### ### ### - Started install/update of package: WindowsFileSystemiDataAgentAdvanced...
14068 1     08/23 19:21:04 ### ### ### - Apply packages completed ...  Status = 0
14068 1     08/23 19:21:04 ### ### ### - Package installation completed.
14068 1     08/23 19:21:04 ### ### ### - Extracting file [C:\Program Files\Commvault\ContentStore\Base\SQLSMOAssemblies\CvSmo2017Dll\CvSQLSMO2017.see] ...
14068 1     08/23 19:21:05 ### ### ### - Update installation is in progress...
14068 1     08/23 19:21:05 ### ### ### - Please check [C:\Program Files\Commvault\ContentStore\Log Files\UpdateInfo.log] for granular details
14068 1     08/23 19:23:27 ### ### ### - Warning: ["C:\Users\adm_balassa2\Desktop\WinX64\BinaryPayload\LooseUpdates\InstallUpdates.exe" -doNotUpdateDB -nostartsvc -silent -vm Instance001 -delayedreboot -ignorePendingFileOp -galaxyinstall -tolerateMissingReg -binaryOnly -earlyInstall    -cvinstaller ] exit code -1073741515 
14068 1     08/23 19:23:27 ### ### ### - Set application exit code=[Failed]
14068 4     08/23 19:23:27 ### ### ### - Showing dialog : CompletionExitViewModel .......
 

icon

Best answer by Aplynx 23 August 2021, 19:35

View original

4 replies

Userlevel 6
Badge +13

Run a repair against any installed C++ version.

If C++ 2017 is not installed, please look to install that as well.

Userlevel 1
Badge +2

All the below components installed properly.

 

 

Userlevel 6
Badge +13

That .dll is part of C++ and is generating the error when CommVault tries to access it for the installation. You will likely see a corresponding error being generated in the OS logs as well.

Userlevel 1
Badge +2

Looks good now. Installation completed

Reply