Solved

Restoring mailbox from Offline Exchange DB, job stops after 24 hours and getting throttled

  • 14 December 2021
  • 10 replies
  • 204 views

Badge +1

I`v been back and forth with support on this for 2 weeks now, doesn't seem to be getting anywhere, figured i`ll ask here

 

11.24.21

Exchange 2019

i have a mailbox from offline DB , I create the offline restore point in CommCell console, then proceed to browse the mailbox for restore (big one ~80gb) to a different mailbox created for this job.

 

issue is I'm getting throttling alerts in ExMiningAgent log , I've already covered the new throttling policy for Commvault article and added the service account, Exchange servers were restarted for good measure.

article about policy:

https://documentation.commvault.com/hitachivantara/v11/essential/93369_setting_throttling_policy.html

also added destination mailbox to policy (was asked by support)  , still same

 

issue is the mailbox is so big and it gets throttled so bad after 24hours exactly job crashed before it can finish ,support asked me to add additional settings on media server and it didn't help (services were restarted)

Name:nDMRSIDLETIMEOUT
Category:EventManager
Type:Integer
Value:432000

 

Would love any input if anyone encountered this before

 

icon

Best answer by Mike Struening RETIRED 8 March 2022, 18:29

View original

10 replies

Userlevel 6
Badge +14

Hello @TomerA 

This is FR24 and Exch 2019 so its leveraging EWS for the recovery. I think you can remove that key as its not needed here.

You should leverage the following for throttling policy. NOTE: This is different than the MAPI throttling setup as it is leveraging EWS!

https://documentation.commvault.com/11.24/expert/112073_configuring_service_account_to_manage_exchange_2019_messages_using_exchange_web_services.html

If that does not resolve the issue, can you try a adding a couple more accounts and see if you get similar throttling errors? Side not just curious have you attempted a restore to PST if you have Outlook X64 2003 installed?

 

Badge +1

Hello @TomerA 

This is FR24 and Exch 2019 so its leveraging EWS for the recovery. I think you can remove that key as its not needed here.

You should leverage the following for throttling policy. NOTE: This is different than the MAPI throttling setup as it is leveraging EWS!

https://documentation.commvault.com/11.24/expert/112073_configuring_service_account_to_manage_exchange_2019_messages_using_exchange_web_services.html

If that does not resolve the issue, can you try a adding a couple more accounts and see if you get similar throttling errors? Side not just curious have you attempted a restore to PST if you have Outlook X64 2003 installed?

 

I've actually tried that article first,  i`v pretty much at this point set most settings in policy to ‘unlimited’ ,didn't change anything

 

as for PST , it works fast , but i was specifically asked by client to use the functionality of restoring directly to mailbox

Userlevel 6
Badge +14

@TomerA Have you attempted to add additional service accounts?

What type of messages are you seeing in the logs referencing throttling? What happens if you recover a smaller folder for that same mailbox I assume it completes without issue?

Badge +1

@TomerA Have you attempted to add additional service accounts?

What type of messages are you seeing in the logs referencing throttling? What happens if you recover a smaller folder for that same mailbox I assume it completes without issue?

 

This and alot of it , it would work for a few minutes and throttle another 5 , for hours


18756 9     12/14 13:29:00 176751 ### CreateItem::CreateMessage - Item restore encountered throttling, so delaying the next request by 5 mins.

 

if this job was smaller I'm guessing i wouldn't have noticed issues since it would just take alot of time , but since its a really big mailbox each time i run this it progress 50-100k items and skip 600-700k items from earlier run , each time it gets closer to 24hour crash before it finishes skipping existing items.

Userlevel 6
Badge +14

Thanks @TomerA 

There was an update that addressed some throttling for the proxy machines you mentioned 11.24.21 is that installed on the machine where you are performing the live browse? 

Thanks

Badge +1

Thanks @TomerA 

There was an update that addressed some throttling for the proxy machines you mentioned 11.24.21 is that installed on the machine where you are performing the live browse? 

Thanks

Hi Scott,

Hi tried again this weekend after updated all the enviroment to 11.24.25 , still same results 

Throttling and job ends after 24 hours exactly.

Userlevel 7
Badge +23

Hi @TomerA , hope all is well.  Can you open a case for this issue and share the number with me?

Apologies for the delay, just got back from holiday :nerd:

Badge +1

Hi Mike, 

My case is still being looked at , last update i got was that dev team will be looking at it.

 

Case:

211117-441

Userlevel 7
Badge +23

Thanks, @TomerA !  Looks like dev is expecting an update from them by this Friday.

Userlevel 7
Badge +23

I can see that the case was Archived with this fix provided:

Commvault_Maintenance_11_24_34_WinX64.ex

Reply