Question

Java update on Commvault servers

  • 20 December 2023
  • 2 replies
  • 107 views

Badge +5

Hello all!

We have received a request to update Java on our Commvault Servers - Comservers and media agents.

Are there any dependencies between Commvault Services and Java version which we need to keep in mind? Are You aware of any “compatibility” matrix for Java version and Commvault? Can we just easily upgrade Java and should not be worry about Commvault Services?


2 replies

Userlevel 6
Badge +15

@Grzegorz 

Hope you are well.

We have a couple of KB articles that should help you out here:

https://kb.commvault.com/article/81232
https://kb.commvault.com/article/57019

If you search BOL under the feature release you are running, you can search ‘third party applications’, this usually provides the version number of the app that we support e.g.

https://documentation.commvault.com/2023e/expert/third_party_applications_installed_by_commvault_installer.html
 

Hopefully this helps!

Regards,

Chris 

Userlevel 6
Badge +18

We have received a request to update Java on our Commvault Servers - Comservers and media agents.


To be clear, as I think it’s often not understood, Commvault bundles a JRE within its releases.  As you upgrade your Commvault versions, we’re upgrading the JRE versions, too.

If you’re talking about Java versions found in the Control Panel | Programs and Features, these are not used by Commvault and can be upgraded, removed, or whatever you desire.

e.g.
# cat /opt/commvault/jre/release | head -5
IMPLEMENTOR="Eclipse Adoptium"
IMPLEMENTOR_VERSION="Temurin-17.0.8+7"
JAVA_RUNTIME_VERSION="17.0.8+7"
JAVA_VERSION="17.0.8"
JAVA_VERSION_DATE="2023-07-18"

Thanks,
Scott
 

Reply