Solved

Aux copy properties showing Media Not copied "Stream No./Sequence" column containing "stream" 0/1?

  • 27 May 2022
  • 6 replies
  • 164 views

Userlevel 2
Badge +11

I have some Aux copies that have this, for example:

The Aux copy is configured to use 8 streams via “Combine source data streams = 8”.  Multiplexing is not enabled.  When it runs (in properties → Streams tab)  it has 8 “Destination Streams” running (“Number of readers in use = 8 ). BUT when I look at properties → “Media not Copied” tab, it shows 9 streams in the "Stream No./Sequence" column, where it is:

what's “0/1” → Stream Number 0? but if so then there’s 9 streams to copy?  I wanted to make sure something was not misconfigured somewhere and Stream No 0 wasn’t some default to handle an oddity/overflow of data or something strange.  I was under the impression the streams were to be combined to 8 (all data broken up into 8 chunks to be streamed/read/copied) … yet the UI is telling me I have 8 streams “to copy” and another one named 0, though it actually only runs 8 streams/readers.

 

For reference, here's the active streams of the same job showing 8 readers/streams

 

icon

Best answer by tigger2 2 June 2022, 18:29

View original

6 replies

Userlevel 7
Badge +23

@tigger2 , good question!  I asked around and I can’t get a definitive answer.

I’m going to ask around to see if I can get a developer to advise.

Userlevel 7
Badge +23

I just heard back from development who suggested creating an incident with an uploaded database so they can find out what the stream is. 
 

Let me know the case number once you do. 
 

thanks!

Userlevel 2
Badge +11

@Mike Struening : Case created just now: 220531-691

There is a different job running currently that’s writing to tape, and I updated the case with that job ID.  the logs I uploaded are for the job ID in the screenshots above. I’ve seen this “Stream 0” before so I’m betting its in multiple jobs/aux copies I just haven’t gotten around to try to find out what it is until now

Userlevel 7
Badge +23

Awesome.  I’m definitely going to keep an eye on it!

Userlevel 2
Badge +11

Support responded and, essentially:

We have the “Storage Policy” → Properties → “General tab” →  “Distribute data evenly among multiple streams for offline read operations” setting checked/selected. When selected, the data is evenly distributed across multiple streams.

They indicate that seeing a Stream 0 is expected behavior as its the staging area used before the streams are split up to evenly distribute the data among the streams.

I think I haven’t seen this “normally” as in the past we didn’t have this setting set on a lot (if any) of our storage policies, and I have gone through and made attempts to “standardize” as many of the settings as I can (when it makes sense) to increase throughput,etc, so to me “Stream 0” is a new stream I don’t remember seeing, but it makes more sense of how/why it “appeared” and what its doing there.

Userlevel 7
Badge +23

That’s quite illuminating!

Thanks for sharing the answer with us!  I’ll go ahead and mark it as the answer for posterity!

Reply