Solved

Badly marked LTO8 tapes

  • 8 September 2021
  • 5 replies
  • 2168 views

Userlevel 4
Badge +13

Hi all,

 

We have a following issue. The LTO8 tapes were badly marked with LTO6 barcodes. Then, the tapes have been remarked with right barcode. However, Commvault can not recognise the newly remarked tapes - Commvault says that the barcodes had been already used and tapes were moved to retired group. We tried to perform Discover,  Full Scan (inventory) and Update barcode for the given tape without success. Is there any workaround for the issue? Is there only one way to somehow fix the tapes within the tape library?

icon

Best answer by Stuart Painter 8 September 2021, 14:22

View original

5 replies

Userlevel 7
Badge +15

Hi @drPhil 

Thanks for the question.

We have some documentation for troubleshooting this kind of issue that looks like it will help here.

Expert Storage Configuration - Troubleshooting

Symptom

When Mounting Media for backup or Auxiliary copy job, the following error occurs:

Error Code 62:280

Failed to mount media with barcode [...], side [...], into drive [...], in library [...] on host [...]. Reason: The media in the drive already has a valid On Media Label and is not a spare. Advice: Please check to see if the Library configuration is correct.

Cause

This means that the physical barcode and the On Media Label (OML) written to the media does not match. This could happen for one of the following reasons:

  1. Media has been re-labeled with a different barcode and the software reads the old media label on the media from when it had a different physical barcode.

  2. Environment issues occurred which caused the SCSI access path to change to the tape drives so while media was mounted in the drives the Commvault software was looking at the wrong media while performing the comparison of the physical barcode and the media label written to the tape.

  3. Slow mapping for the tape library was not accurate at the time the tape was mounted in the drive.

  4. A standalone tape drive is used and the media that is being used already has an On Media Label (OML) and is not a spare.

Resolution

To resolve issue, perform one of the following:

  • If this is a Standalone drive and this error is received then replace the media with a new spare media.

  • If this is a Library then first perform a full scan on the library to make sure that the slot mappings have been updated in the CommVault Software.

    Once the scan is complete, verify the Media Label written to the media matches the physical barcode of the media by performing the steps described in TapeToolGui utility.

If the Media Label written to the tape matches the barcode

If the media label written to the tape matched the barcode on the media then the media can be marked appendable again if it was previously marked bad with Media Label errors. To mark a tape appendable:

  1. From the CommCell Browser, select Storage Resources | Libraries | <Library Name> | Media by Location | Media in Library.

  2. Right-click the media, point to Options, and then click choose the Mark Appendable.

  3. A message appears, that asks you to confirm whether you wish to mark the media as appendable. Click Yes.

  4. The media status is changed to Appendable with the reason stating User marked appendable. (Media status can be viewed in the <Media ID> tab of the Media Properties dialog box.)

  5. The media will display a blue and yellow icon.

If the Media label written to the tape does not match the barcode

If the Media label written to the tape does not match the barcode on the tape because the media was re-labeled or if the tape has invalid data, use TapeToolGui utility to format the media.

If the tape has valid data then contact your software provider.

 

Note: Misuse of the TapeToolGui utility can result in data loss. We recommend you to contact your software provider to resolve this issue.

 

TapeToolGui

 

Please make note of the warning for using TapeToolGui and if you’re at all unsure, please contact support for assistance.

 

Thanks,

Stuart

Userlevel 6
Badge +15

Hi @drPhil 

Can you tell if some data has been written on the tapes between the LTO8 barcodes have replaced the LTO6 barcodes ?

Do you just need to ‘erase’ those tapes and have Commvault be able to use them, or do you need to access the content of the tapes, to be able to restore, from them ? 

 

This could be easily solved if you need to just erase and use the tapes.

If you need to access the content stored on those tapes before the new labelling, then… :drooling_face::zipper_mouth:

Do you still have the previous LTO6 labels /stickers ?

Userlevel 4
Badge +13

Hi @Stuart Painter, @Laurent ! Fortunately, there are no data on the tapes at all. The tapes are brand new. I was playing around with TapeToolGui, however I was not able to figure out how to  ‘erase’  bad/old barcode and make tapes working and visible. As said, bad LTO6 barcodes have been replaced with correct LTO8 barcodes, however, Commvault does not recognise these new correct labels.

 

 

Userlevel 6
Badge +15

Hi @drPhil

To use the tapetoolgui I recommend you to disable your tape library in Commvault before operating.

AFAIK, It only can operate with the tape in the drive. It means that you have to manually move a tape to the drive first (using library admin console, for example), and when done, use the tapetoolgui.   

Try to select read label, select the Tape Name if possible, and click start. It should print the details of the tape in the Operation Results.

Then you can try to ‘format‘ that tape first. Then resume the activity of the library in Commvault, and fullscan, to see if that one tape has changed. If so, repeat with the other media.

 


But, before using this, have you tried to go into the ‘retired group’ and click on each tape, and select All tacks/Delete and confirm ?

 

Userlevel 4
Badge +13

Fortunately, it was just enough to do Full Scan of the library and then after some time the tapes have been visible and working in the Commvault environment. Thanks to @Stuart Painter and @Laurent for help and good tips.

Reply