Solved

Create a tape job for new full backup


Userlevel 3
Badge +13

Hello,

I need to create a backup job with all full backups to tape in a physical library(new library) that the customer has purchased.

Today all backups are on disk (File Library).

After the new Jobs to tape has been succesfully executed (3 backup jobs to tape will be done), i need to erase the full backup, which today is very old and needs to be done a new full backup, because the size will be smaller and will free up more space in disk.

Wait guys for the best practices to do this.

Another question: i will create the Storage Police for the library with permanente retention and include all tapes in the same SP or create other for example: Database, Exchange, etc.

@Mike Struening 

icon

Best answer by Fernando Souza 20 August 2021, 18:52

View original

25 replies

Userlevel 7
Badge +23

Hey @Fernando Souza !

To summarize and confirm I have it right, you need to send all of the Full backups from the Disk/Primary Copy to a new tape library, then erase the older copies on the Primary/disk copy once they are complete.

Is that right?

If so, that’s simple enough to accomplish.  Assuming the library is already installed, you need to create a Selective Aux Copy.

You can set this copy to either copy ALL Full backups, or manually select the ones you want.

https://documentation.commvault.com/commvault/v11/article?p=13907.htm

Note there’s an option to Manually Select the Backup jobs.  If this is a one time operation and there are not that many Full backups, this might be the best path for you.

Take a look and let me know if you have any questions!

Userlevel 3
Badge +13

Yes, you are correct, but i think is only one backup job(i think), tomorrow i will verify this.

i will make the “selective aux copy”.

But i will make this procedure in the customer and if i have a doubt, i put here, ok @Mike Struening 
thanks for help. :grinning:

Userlevel 7
Badge +23

Ok, you’re on the right track then.  Just make a Selective Aux Copy using the Manually Select options.  Essentially, you’ll pick “Do not automatically select the jobs” because YOU are going to pick the job afterwards.  Since it’s only once job, once you run the Aux Copy and it completes, you’re done (until next time)!

Hit me up if you have any questions!!

Userlevel 3
Badge +13

@Mike Struening Nice.

I wiil make this and send a message to you. many thanks. :clap_tone1:

Userlevel 3
Badge +13

Hello @Mike Struening 

The first case to do is format media(8 tape media) in the library and how can i do this?

Userlevel 7
Badge +23

@Fernando Souza , assuming the tape is in the library, you can just right-click and delete the contents.

You can also use the tapetoolgui to do so:

https://documentation.commvault.com/11.24/expert/10587_tapetoolgui.html

Userlevel 3
Badge +13

 

Hello @Mike Struening 

I researched amd did the procedure through tapetoolgui, but gave a compatibility error, and tried to do it through the library, move a tape to the drive, a compatibility erros occurs.

#tapetoolsgui
 

 

The customer bought:
 

 

I think the problems with the compatibility of barcode and the drive.

Userlevel 7
Badge +23

According to the Fujitsu page, the drive supports LTO7 tapes and that looks like what they bought:

https://www.fujitsu.com/global/products/computing/storage/tape/eternus-lt/lt20/

If you select format, does it work then?  does this tape show up in the CommCell console?

 

Userlevel 7
Badge +23

Also sharing this which MIGHT apply about an issue addressed in 11.20.43:

https://documentation.commvault.com/commvault/v11/article?p=11_20_60.htm

Would hate to not share it and find out that was the issue!

Userlevel 3
Badge +13

@Mike Struening the tape library show up in the comm cell.
 

 

Userlevel 7
Badge +23

You should be good to go.  I would run a test backup for a small job just to confirm.

Does the property screen show it as LTO7?

Userlevel 7
Badge +18

You should be good to go.  I would run a test backup for a small job just to confirm.

Does the property screen show it as LTO7?

You can also run a validate drive operation on the library to write some random test data (it will pull from available scratch media)

Userlevel 3
Badge +13

Hello,
@Mike Struening 
@Damian Andre 
The tape photos in the library:

LTO7

The barcode:


 

 

Userlevel 3
Badge +13

I think this:
 

 

Userlevel 3
Badge +13

https://www.ibm.com/docs/en/ts4500-tape-library?topic=media-lto-type-m-cartridge-m8

Userlevel 7
Badge +23

@Fernando Souza , I’m looking at your last screen and it looks like M8 tapes need LTO 8 drives….I think you are right, the customer has the wrong tapes.

Userlevel 3
Badge +13

Hello guys 

@Mike Struening and @Damian Andre 

I need to create 2 auxiliary copy for 2 SP:
-SP_FilesServer_Exchage
-SP_SQL

This was previously done by someone else.

It was made for send the SP to other local and need help to do this, dont have documentation about this.

Question: Why the SP is in the red color?

Dash_Copy_Port: i think is the second copy to go to Porto.

I need help to understand this.

Userlevel 3
Badge +13

Hello @Mike Struening yeah, i talk to the Fujitsu and pass the information that i searched and requested to open a case to pass to the Manager vendor that make a sold. Thanks.

Userlevel 3
Badge +13

The SP_FileServer_Exchange:

The SP_SQL:
 

 

Userlevel 3
Badge +13

The last time they did Auxiliary Copy to Porto: 17/03/2021 and 19/03/2021:
SP_FileServer_Exchange:

 

Userlevel 3
Badge +13

The last time they did Auxiliary Copy to Porto: 19/03/2021:
SP_SQL:

 

Userlevel 4
Badge +9

Hello guys 

@Mike Struening and @Damian Andre 

I need to create 2 auxiliary copy for 2 SP:
-SP_FilesServer_Exchage
-SP_SQL

This was previously done by someone else.

It was made for send the SP to other local and need help to do this, dont have documentation about this.

Question: Why the SP is in the red color?

Dash_Copy_Port: i think is the second copy to go to Porto.

I need help to understand this.

Hi @Fernando Souza 

If I’m understanding correctly there’s a couple points of concern here.
- Create a new storage policy copy for two storage policies
- Inquiry as to why specific storage policies show as red


Creating a storage policy copy:
- Right click on the desired Storage Policy > All Tasks > Create a new copy
https://documentation.commvault.com/commvault/v11/article?p=13900.htm

 

Storage Policy copies with red text and a warning icon on the policy
- The red text and warning icon indicates a Storage Policy Copy has fallen behind
https://documentation.commvault.com/commvault/v11/article?p=3937.htm
- Information on resolving a fallen behind scenario
https://documentation.commvault.com/commvault/v11/article?p=11519.htm
- Report to view all aux copies that have fallen behind
https://documentation.commvault.com/commvault/v11/article?p=38030_1.htm

 

Let me know if I missed any other parts to your remaining concerns here.

Userlevel 3
Badge +13

Hello @Sean Crifasi 

My question: Can I run these Dash Copies that were run in March,? For example:

I think they only ran it in March to copy this to another site(Porto), correct?

it wasn´t synchronous copy, is this correct? 

Userlevel 4
Badge +9

Hi @Fernando Souza  

You need to create or modify a schedule and associate it to the desired storage policy copy
https://documentation.commvault.com/commvault/v11/article?p=11520.htm

Right click on the storage policy copy in question > view > schedules > this will confirm if any aux copy is presently associated to the copy in question and if it is currently enabled.

The reason for that warning is not based upon ‘last backup time’ If you view the summary of the storage policy you will see another section for ‘to be copied’ and that is what is triggering the red text and warning icon.

Userlevel 3
Badge +13

Hello,

I started the auxiliary copy jobs and they are running the copy to Porto.

I saw the settings and they were correct.
When finished, send message.

Thanks

 

Reply