Question

I/O Device error occurred in Tape Library

  • 22 January 2024
  • 9 replies
  • 202 views

Userlevel 1
Badge +8

Hi Team,

Greetings!!!

 In our  Tape library there is an error for one single tape “The request could not be performed because of an I/O device error” and the Media status is showing “full” but actually this tape is not fullafter that  this tape is not writing any more.

please see the tape size details

Native capacity of Tape: 11.72 TB

Size of stored data:1.31 TB only

CommServe current version:11.28.24

Could you share any solution for this issue


9 replies

Userlevel 2
Badge +7

@Adarsh.op - Good day!

 

If we hit into any read/write errors then we do have a threshold for it to mark the media as bad which could be the reason for marking the tape media as bad. 

 

Can you please check the properties of the problematic media and see if there are any read/write errors? 

 

if yes, then it shouldn’t be used for any operation. 

Kindly let me know if you have any queries. 

Userlevel 1
Badge +8

Hi Arun,

Greetings!!

Thanks for your valuable reply,

We will check the Media properties but there is no Read write error in Tape it showing “0”

Only the Number of Media label errors is showing “1”

Please suggest any other solution for this issue 

Userlevel 4
Badge +11

Hello @Adarsh.op 

You can check cvd.log, CVMA.log and LibraryOperation.log for more information on the issue with the problematic tape. 

To check it from OS end, you can check event viewer logs if its hosted on Windows or /var/logs/messages if its on Linux when any operation is tried against that tape. 

Moreover, you can also attempt to read the media using tapetool on the MA and try to read the media and accordingly can proceed: 

TapeTool - Windows (commvault.com)

Best,

Rajiv Singal

Userlevel 2
Badge +7

@Adarsh.op - One media label error shouldn’t make the tape as full. Can you append the media for reuse? 

https://documentation.commvault.com/2023e/expert/media_operations_configuration.html#reuse-media-marked-as-appendable

Userlevel 1
Badge +8

@Arunkumar P 

But the Tape status showing full and it not write,  Also the tape having data(1.31TB), while append the media data will be erasing or not??

Userlevel 2
Badge +7

@Adarsh.op - No, it won’t erase the data. Go ahead and mark the media as appendable. 

Userlevel 1
Badge +8

@Rajiv 

Thanks for your valuable reply

 I will check and update to you

Userlevel 1
Badge +8

@Arunkumar P 

Thanks for your reply , I Will check and update to you

Userlevel 1
Badge +8

@Arunkumar P 

 Hi Arun,

While Mark the media as appendable. after append we can reuse this tape? if there any option for moving the data from this tape to another free spaced media?

also our some  media are partially complete in the pool and next time backup jobs are writing on the new tape it will not write the existing free spaced media.

could you please suggest any solution.

Reply