Solved

Running Auxiliary Copy overlaps with Primary schedule

  • 17 March 2022
  • 9 replies
  • 263 views

Userlevel 2
Badge +6

Hello,

I need a little clarification about long running Auxiliary Copies.

On a daily basis we run a Primary Copy schedule which is followed by three auxiliary copies. Quite often the auxiliaries take a very long time to complete, enough to overlap with the primary copy schedule of the following day. This makes the jobs on day 2 to “enter” the still running auxiliary copies from day 1, is there any way to avoid this? Is it possible to set a boundary on the latest job to be included in an auxiliary copy?

To my understanding, the Copy Policy->Backup Period->End Time setting cannot be used as it would provide a fixed date rather than a moving one.

Sorry if this sounds a bit dummy and thanks for you support

Gaetano

icon

Best answer by Matt Medvedeff 17 March 2022, 18:43

View original

If you have a question or comment, please create a topic

9 replies

Userlevel 3
Badge +9

Hi Gaetano,

It is possible to adjust the behavior of the Aux copies so they do not automatically add new jobs to copy to the already running Aux copy jobs.

Can you check if the Pick new data for Scalable Resource Auxiliary Copy job parameter is set to 1 or 0? This setting can be found in the Commcell Console → Control Panel → Media Management → Auxiliary Copy tab.

Here is the documentation regarding this option

https://documentation.commvault.com/11.24/expert/11015_media_management_configuration_auxiliary_copy.html

Based on your description, you would want to set this parameter to 0 to only copy the jobs that are in a To Be Copied status when the Aux copy is first launched.

Let me know what you find and if this answers your question. Thanks and have a great day.

Userlevel 2
Badge +6

Matt, you may have just made my life better with your answer!

The value is 1, I will change it to 0 and offer a beer to my colleagues :blush:

 

Thank you!

Userlevel 7
Badge +23

That’s a legendary response!!

Userlevel 2
Badge +6

I got @Matt Medvedeff ‘s reply while commuting from work, afterwards I changed the value of the suggested parameter from 1 to 0, will check how it goes but I am really confident that it will put many things straight.

What is it going to happen to the currently running AC? Will they pick the new value or they need to be killed and restarted?

Have a great day!

Userlevel 3
Badge +9

Hi @Gaetano - It will not apply to Aux copy jobs in progress when the parameter was changed, so any jobs running at the time should be killed and restarted for the new setting to take effect. The jobs will resume copying from where they last left off.

Let me know if you have any further questions. Have a good one

Userlevel 2
Badge +6

Hi @Matt Medvedeff , thank you!

Checking the documentation about this option I read:

Ensure that the Use Scalable Resource Allocation option is selected in the Auxiliary Copy Job Options window displayed during auxiliary copy execution.

Note: To prevent the Auxiliary copy jobs from picking new data for replication, add the registry key QueueConflictingAuxCopyJobs and set the value to 1.

 

Do I have to add the mentioned registry key along with setting Pick new data for Scalable Resource Auxiliary Copy job parameter to 0?

Userlevel 3
Badge +9

Hello @Gaetano 

I don’t believe you need to set the registry key to get the Aux copies to behave as you intend. 

And yes you will need to ensure Scalable Resource is enabled on the Schedule of the Aux copy, but based on your description of the current behavior of the Aux copies I am sure it’s enabled.

Userlevel 2
Badge +6

Hello,

sorry to come back on this topic butI am afraid Aux copies are not behaving as expected.

@Matt Medvedeff , the copies here started between two days and one day ago, as you can see from the screenshot

but, if I go and check the job details of the first one (293297) I find the following

There are many jobs run today and yesterday that are marked To Be Copied even if they shouldn’t be, am I correct?

Same happens for the other Aux copies.

I changed the parameter Pick new data for Scalable Resource Auxiliary Copy job to 0 on 03/17, am I missing anything?

Thank you in advance

 

Gaetano

 

Userlevel 2
Badge +6

For the sake of completeness, I confirm that Scalable Resource is enabled.

Auxiliary Copy Job details dialog

Thank you again for your time