Question

HyperScale 1.5 - HBA - VSA SAN backup

  • 20 November 2023
  • 3 replies
  • 53 views

Userlevel 2
Badge +6

Hi All.

 

I have a HyperScale 1.5 setup, with HBA cards installed on the nodes to be able to do VSA SAN backups.

I have configured the multipath.conf to use round-robin, so the HBA card will utilize both ports on the card

 

I have noticed that even though round-robin have been configured, it seems that only on port is utilized and that the port being used is then being maxed out.

Do I miss somewhere in the HyperScale configuration where I can set the multipath setting or does anyone have any suggestions on how to utilize both ports on the HBA in a HyperScale setup?

 

Regards

-Anders


3 replies

Userlevel 6
Badge +14

Hi @ApK 

I think multipath should already be enabled by default, could you run the following and share output?

systemctl status multipathd

Regards,

Chris 

Userlevel 2
Badge +6

Hi @Chris Hollis .

 

The command returned with the below output:

 

[root@XXXXX ~]# systemctl status multipathd
● multipathd.service - Device-Mapper Multipath Device Controller
   Loaded: loaded (/usr/lib/systemd/system/multipathd.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2023-11-16 12:00:46 CET; 1 weeks 5 days ago
 Main PID: 7910 (multipathd)
   CGroup: /system.slice/multipathd.service
           └─7910 /sbin/multipathd

Nov 27 17:30:55 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 27 23:31:19 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 27 23:31:19 XXXXXXX multipathd[7910]: dm-448: devmap not registered, can't remove
Nov 27 23:31:19 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 28 05:30:37 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 28 05:30:37 XXXXXXX multipathd[7910]: dm-448: devmap not registered, can't remove
Nov 28 05:30:37 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 28 11:36:25 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
Nov 28 11:36:25 XXXXXXX multipathd[7910]: dm-448: devmap not registered, can't remove
Nov 28 11:36:25 XXXXXXX multipathd[7910]: dm-448: remove map (uevent)
[root@XXXXX ~]#
 

Regards

-Anders

Userlevel 6
Badge +14

Thanks @ApK 

Looks good.. should be functioning as far as I’m aware. May be something at the OS level we need to fix up.

I think we should look at this via an official support case to ensure we’re not missing anything and if escalation is required, we get that done asap.

Please let me know the ticket number once you’ve raised it so I can monitor and we can update this thread with our findings.


Regards,

Chris

 

Reply