Question

MSSQL SA User Password Invalid.

  • 1 March 2024
  • 2 replies
  • 98 views

Badge +1

Hi Folks,

I am trying to install Commvault 11.34 Trial on Windows 2019 Server. However, in the final stage of the installation process, Commvault is asking for the SQL Server sa user password. After changing the sa password several times using SQL server management studio, checking if the user logging is enabled, etc.. it’s still returning as invalid password.

 

NOTE: The SQL server was installed by Commvault 11.34 installation package.

How can I fix this issue?

Thanks

 

 


2 replies

Please check the install.log under installation path [\ContentStore\Log Files] folder and SQL Server logs…

More importantly, such issue should not be faced if the SQL server installation was done during Commvault installation.

Badge +1

Hi Jacek,

Thank you for the answer.

This issue is fixed now. For some reason, it seems the installation process (screen above) was not passing my correct MSSQL sa user password or maybe it was using a different one. Any ways, below are the “steps” I put together to mitigated this issue.

 

1/ Run the Commvault installation trial again to remove most of the Commvault installed items

2/ Reboot windows server

3/ Update MSSQL SA user password again via MS SQL Management studio.

Double checked my MSSQL SA user configuration, which was also set since the beginning of the installation.

  • On MSSQL, ensure the authentication mode for the SA user is set to “Mixed Authentication” SQL server Windows authentication.
  • Ensure the SA user logging is enabled
  • Set a new password to the MSSQL SA user

4/ Restart MSSQL DB

5/ Run the Commvault installation trial again

6/ Enter the new SA user password, then it will work.

 

Thanks

Andy

Reply