Solved

Snapshot creation is disabled on [Server name] by []

  • 20 September 2023
  • 44 replies
  • 4523 views

Userlevel 2
Badge +6

Hi all.

 

After upgrading to 11.32.13 we are sporadically starting to see the below error when doing Vmware snapshot backup. The backup job fails or completes with errors:

 

“Snapshot creation is disabled on [Server name] by [].” 

 

Snapshot creation is not disabled for the server, and when backup is re-run everything is working.

 

Have anyone else seen this behavior?

 

Regards

-Anders

 

icon

Best answer by Sebastien Merluzzi 20 September 2023, 12:03

View original

44 replies

Userlevel 6
Badge +14

Hi @ApK ,

This has been fixed in Hotfix 8847, MR will be available soon.

You can log a case or I will let you know which one asap.

Best Regards,

Sebastien

Userlevel 2
Badge +6

Hi @Sebastien Merluzzi

 

Thanks for your reply, good to know that it is a know issue and will be fixed soon.

 

Do you know if the hotfix is part of the October MR? Else I will log a case to get the hotfix.

 

Thanks

-Anders

Userlevel 6
Badge +14

@ApK ,

It might take 1-2 weeks or we can provide the Hotfix if you log the case.

Best Regards,

Sebastien

Userlevel 2
Badge +6

Hi @Sebastien Merluzzi Sebastian.

 

I have created a case to get the hotfix.

 

Regards

-Anders

Userlevel 6
Badge +14

@ApK 

What is your case number?

Userlevel 6
Badge +14

That’s fine, found it.

Userlevel 2
Badge +6

@Sebastien Merluzzi

Perfect, I’ll await the hotfix.

Userlevel 6
Badge +14

@ApK ,

I see we have provided it now.

Let me know if the Hotfix fixed it.

Userlevel 2
Badge +6

@Sebastien Merluzzi,

 

The hotfix did not fix the issue. I have uploaded logs for a failed job to the case.

 

Regards

-Anders

Userlevel 6
Badge +14

@ApK ,

Actually you need a key too.

Let me know

Best Regards,

Sebastien

Userlevel 2
Badge +6

@Sebastien Merluzzi 

 

The additional setting did the trick.

Do you know if I can remove the additional setting again, after the fix is part of a future MR?

 

Userlevel 6
Badge +14

@ApK ,

You cannot remove it.

The Additional setting is to not perform the pre-check at all, and instead directly call the create snapshot API.

Best Regards,

Sebastien

Userlevel 1
Badge +12

@Sebastien Merluzzi 

 

We having the same issue with the snapshot disable on the vm backup and we are running 11.30.64

 

What addition szestting do i need to add and where? On commserver? 

Userlevel 2
Badge +6

@Egor Skepko 

You set it on the VSA/MediaAgent.

 

additional key:
Name: bVerifySnapshotCreationAllowed
Category:VirtualServer
Type: Integer
Value: 0
 

Userlevel 1
Badge +12

@ApK Do you need to restart commvault services on MA after? 

Userlevel 2
Badge +6

@Egor Skepko No, that should not be necessary, at least not on HyperScales. Not sure if you have windows MediaAgents.

Userlevel 6
Badge +14

@Egor Skepko 

You do not need to restart the commvault services for the additional setting to take effect.

32.28 will be out next week.

Userlevel 1
Badge +12

@Sebastien Merluzzi We are running 30.64 atm, wil it be there aswell?

Userlevel 6
Badge +14

@Egor Skepko 

Yes in 30.72.

Badge +1

@Egor Skepko

You set it on the VSA/MediaAgent.

 

additional key:
Name: bVerifySnapshotCreationAllowed
Category:VirtualServer
Type: Integer
Value: 0
 

Do you have the Path on the MA where this Key is set? - I’m having the same issue !

Userlevel 6
Badge +14

HI @AndyC ,

The key is a workaround, can you upgrade to latest MR?

Badge +1

Hi Sebastien

 

Thanks for the prompt response, I cannot update to the latest MR as there is a strict Change Control/Freeze in place at present.

So the Key workaround would help.

Userlevel 6
Badge +14

ok, so the path is the category, VirtualServer

Just need to add the Additional Setting,

Userlevel 2
Badge +12

Hi All,

 

as per documentation: 

https://documentation.commvault.com/v11/expert/files/service_pack/updates/11_32_35.htm

 

The fix should be Included from Maintenance Release 11.32.28 (Nov 07, 2023) and all after. We are running 11.32.35 and have the problem. 

 

Do you know something about that ? 

 

Is the way now set the key ? 

Userlevel 6
Badge +14

Hi @SSchmidt ,

That’s correct, it is already fixed.

You can set the key as a workaround, however the issue can also be different.

So you may log a case with SUpport so we can check & confirm.

Best Regards,

Sebastien

Reply