Migrating Exchange Online Protection from EWS to Microsoft Graph: Post Your Questions Here
Discuss any topic related to storage or deduplication best practices
Recently active
Hello Community,I have a problem, that the Index Cache Directory usage grows steadily (~ 2Gb per week) and currently 80% of free space is consumed.Due to specifics of the environment, Load Balancing and adding free space is almost impossible. As per the CV documentation, the active metadata are deleted from Index Cache, when the corresponding jobs meet retention:https://documentation.commvault.com/2023e/commcell-console/backupset_level_indexing_index_cache_cleanup.html#index-cleanupand the compaction process happens every 30 days by default:https://documentation.commvault.com/additionalsetting/compaction-enforce-days.htmlCan I use the Additional Setting COMPACTION_ENFORCE_DAYS to set another frequency for the Compaction process, e.g. 1 week? I expect, that then the metadata from aged jobs will be deleted every week, rather than every month, and this will free up space in Index Cache.Is this assumption correct?What impact can this setting have on the environment? Best regards, Aleksandr
Hi,I have few questions about compliance lock and the retention of last full backup.How does the retention of the last full backup work in a storage with a compliance lock? Is the retention for the last full backup updated when a new full backup is added at the end of the month? I know that compliance lock can't lower the retention.For example, if a full backup occurred on the 15th day of the month considered as the last full backup of month and the retention is set to 1 year, but on the 30th day of the month a new full backup occurred and it is the real last full backup of the month, does the first full backup will update the retention date even if it is in a storage with compliance lock.Is it recommended to select "Last full backup" for a extended retention job with compliance lock? Do you recommended to use instead "First full backup" with compliance lock? What is the best practice?
Hi guys!I need your help.I am trying to use AirGap Workflow to set proxy cennection between MediaAgent ‘cvmakrk01’ and CommCell Infrastructure.I have created following computer groups. Then I have created the following Networktopology for AirGap workflow. My goal is to push Commvault to use ‘cvproxy’ client to set tje network connnection between MediaAgent ‘cvmakrk01’ and Commvault infrastructure anf the use AirGap workflow to turn on ‘cvproxy’ only for the time of AuxCopy jobs.However, I can see, than even if the ‘cvproxy’ is powered off, the Check Readiness still shows me that ‘cvmakrk01’ is ready. MountPath Validation and AuxCopy job runs as normal.What is important, I tnink, CommServe LiveSync is configured in my environment, so I can also that ‘makrk01’ uses LiveSync network topology for communication. Probably this is the reason, why ‘cvmakrk01’ is always ready. Is any way to set the ‘cvmakrk01’ to ignore LiveSync proxy client and use only ‘cvproxy’ client to communicatio
SQL Backup getting failed with errorEncountered a network error. Could not connect to the CVD on the target MediaAgent to launch the DDB engine. 5884 1be0 12/09 16:19:52 739 <SC: 191> LaunchGroupRemotePart1: Cannot connect to CVD on host [DPCBKP02*DPCBKP02*8400]. Error [0xE8090010:{CCvNetwork::Attach_RemoteDLL(1579)} + {CCvNetwork::Attach_RemotePort(1453)} + {CCvNetwork::GetConnection(3327)} + {CSessionConnectionSocket::GetConnection(240)/EventMessage.0x09000010.9:16.(Remote machine [DPCBKP02]. The socket connect failed. Error returned [-1=Connection failed on sqlclust01: Error in tunnel to DPCBKP02: Connect failed: Failed to connect fd=1096 to 172.18.3.27:8403: Connection timed out]. Check Network Connectivity.)}]5884 1afc 12/09 16:19:52 739 <SC: 191> LaunchGroupRemotePart1: Cannot connect to CVD on host [DPCBKP02*DPCBKP02*8400]. Error [0xE8090010:{CCvNetwork::Attach_RemoteDLL(1579)} + {CCvNetwork::Attach_RemotePort(1453)} + {CCvNetwork::GetConnection(3327)} + {CSessi
Good afternoon everyone.I have a question about Commvault's cloud libraries. A client would like to use Wasabi Object Storage, but I couldn't find any specific requirements in the documentation for using Wasabi as a library. Is there any documentation on this?
Hi,Here is my situation :For a specific server plan, a synthetic full is missing for July and August. We have extended retention for this server plan on AirGap so that one full by month is kept for a year. I have Synthetic full with all VMs of the subclient for : May, June and September but I don't have Synthetic full for : July and August. The difference between these months is that we added a virtual machine in July and August. At the time of addition, there are full backups to back up only the virtual machine we just added. Here is the answer of the support :When a new VM is added to a subclient, Commvault automatically will take a full backup for that VM during the next scheduled backup. If, during July and August, the synthetic full backup for the subclient was not triggered or completed, it may be because the schedule detected that a full backup was required for the newly added VMs. As a result, the synthetic full operation was skipped for those months and instead a full backup w
Hi Team,Im wondering if anyone has any success, or otherwise using S3 standard as a Primary copy.We will be deduplicating.That would not be my preferred option, as I always prefer faster disk than a Cloud-library offering, but the question is being asked.We do have some fairly large databases (a few TB’s) and I’m wondering how the throughput of say a 5TB DB would hold up in a restore situation.It would be good to hear people’s feedback on this subject.Thanks
Hi guys need help for fix below error Error Code: [62:441] Description: Library [XXXXX], MediaAgent [YYYYYY], Drive Pool [], MountPath[\8DC1R1_08.15.2024_16.29]: Internal software error occurred. Advice: If the issue persists, please upload log files from CommServe, MediaAgent and Client and contact your vendor's support hotline with the job ID of the failed job. Source: YYYYYY, Process: ScalableDDBVerf
I have 2 media agents connected to tape library with 8 drives… and they both host a Plan and I can’t seem to have the aux copies to tape to use more than one drive. Each plan has 30 Streams and the aux copies use the primary copy as the source copyEach also have an aux copy going to the other one (01 to 02 and 02 to 01) . In the media tab, I’ve combined source data streams to 2 and I did not multiplex..Should I use the second copy as the source for the tape copy then?I find this whole part a bit confusingthxG
If Compliance Lock is enabled on a Storage Policy, Does it affect anything else in the storage pool?
Hi, I am looking for a complete list of resources from each cloud provider that Commvault is able to protect. It’s currently being used for my VMs, some DBs and AD.
Hi,Please, could you help me with the following question:Currently our customer is using Commvault’s deduplication feature for every copy (primary, secondary).They want to start using hardware deduplication (from their backup storage appliance).Since secondary copies are written to a secondary site, we were wondering if it is possible to disable deduplication just for the primary copy (which would use HW dedup) and enable it only for the secondary one, in order to avoid high network usage between sites. Thanks in advance!
Hi.I’m interested to know if Commvault (11.40) can work with Veritas Access Appliance as Object Storage via S3? I can’t find any documentation on it, but in theory if it’s standards based S3 it ought to be compatible...Thanks.
i have a problem. i changed disks on my storage, i restored backups on new disks. my commvault i proceed that make backups on this storage library, but i receive error notifications Job Management - Auxiliary Copy [Media read operation failure] [Dedupe disk media] [Operating System could not find the path specified.] [in media (CV_MAGNETIC) , Path (\\192.168.170.100\AMS_Backup\Commvault\9ITOLX_09.06.2022_10.40\CV_MAGNETIC\V_10282)] Failed to generate collect file for backup contents [C:\Program Files\Commvault\ContentStore\iDataAgent\JobResults\CV_JobResults\2\0\537187\LogDBList.cvf] or the file size is zero. Possible reasons are 1. nonexistent path/file 2. disk is full or 3. incorrect permissions for the user configured at the instance level or 4. subclient contents are empty and/or Auto-Discovery not enabled.i tested from windows explorer and cmd. i have access this share location on my storage library. What i do?
Hi,Is there any statistic, maybe in logs, what amount of data is send from storage to media agent during restore? In backup we have “Data transferred on network” but what about restore?I mean - let’s say I’m restoring something from Disk Library or Azure - data in library is deduplicated and compressed. I know that dedupliaction doesn’t matter here, but what about comporession? I believe media agent get compressed data from storage, uncompress it and then send to the client? So size of application will be not the same as the data size taken from storage? How to check it? Regards
My customer just testing Storage accelerator in his environment and has some questions.Scenario 11.36 : Client installed with file agent. SA in place and does its work for weeks. Now the connection to the S3 library failed for some reason.We observed that backups still running but without SA (fall back) over a MA.We also observed that backups do not come automatically back to SA if network connection to S3 lib is repaired.We found some keys in registry which may steer the behavior, but we do not completely understand how the software decided to use the Storage accelerator feature or not. If we have no connection to cloudlib the two keys are created.The StorageacceleratorAutodisabledUntil key seems to renew all 24 hoursThe StorageacceleratorConsecutiveFailureCount seems to be increased after timestamp StorageacceleratorAutodisabledUntil was reached if “S3 network connection” is down.Max value is 8 . After this count value SA does not try again to use a direct connection to the S3 libra
Is anyone else getting this error message every time their SynFulls run? 11.36.46 I want to say this stuff started happening when we moved from Server 2012 to 2022, but I don’t think that’s my problem. Windows Server 2022 - CS, MAs, VSA Proxies Every time the SynFulls run, most of them sit there in a Waiting status, yet there is always a single stream that shows Active (some over 24 hours) and always throw this error message, which was supposedly fixed a few MRs ago:Error Code: [19:1926] Description: Some jobs were skipped due to read errors. Will retry after some time. Source: bccmvcs01, Process: JobManager I’m not doing anything special with them. They are Continuous and do a SynFull every 7 days. Any help would be greatly appreciated. I remember when SynFulls would just run, and very quickly I might add, but now they just queue up and eventually finish after a looooong time. We have 4 MAs - each with a piece of the DDB partition. Not sure what other details you may need, but
We are evaluating ways to strengthen our backup infrastructure against ransomware and improve immutability. Below is our current environment setup:Infrastructure Setup CommServe + Media Agent Backup Targets: Primary: Dell EMC Data Domain ( No dedup) Secondary: Auxiliary copy to Azure Blob (Cool ) (De-Dup) Policies: Policy A: 35 days basic retention Policy B: 35 days basic retention + extended retention (Monthly – 365 days, Yearly – 15 months) Exploring Areas for Ransomware ProtectionOn Data Domain to enable immutability. Compliance lock on storage policy copies Within Commvault Has anyone implemented Commvault compliance lock along with DD Retention Lock. if yes what are the recommendations. Appreciate your insights, especially around practical challenges
Hi everyone,I have several commcells. On one of them there are “No data available” on the Comcells, Agents, and Client Groups tiles. All other tiles seems ok. Anybody know why and how to fix it?Also, on my other comcells there seem to be no data from january to july for the same three tiles. I guess there is no way to generate the missing data again, but do anybody know if it is a known bug? RegardsGunnar
Hi Team, We are getting the below error very frequently while running aux jobs. It tells that all device streams exhausted and job will be in pending state until streams become available. Please advise me how to allocate devices streams to avoid this issue. I have increased Parallel data transfer streams on the Media agent level and Device streams on the Storage policy settings- it does not seems to be helping. Please advise me how to define stream values and what are the things we should consider when increasing or decreasing the streams. How it works?
Hi Team,After upgrading to Commvault Platform Release 11.40.13, we observed an issue in the Backup Job Summary Report. The report now shows an additional status – “Completed without Backup.”On review, most of the jobs under this status belong to SQL servers with databases configured in Simple Recovery Model, where TLOG backups are skipped. Although the jobs complete successfully, they are being flagged under this new status, which is impacting the SLA completion percentage in reporting.We would like your guidance on the best approach to handle this: Exclude “Completed without Backup” jobs from the Backup Job Summary report so they don’t affect SLA metrics. Alternatively, create separate schedules for databases configured with Simple Recovery Model (without TLOG backups). Kindly suggest which approach would be recommended or if there is a Commvault-supported configuration change to address this reporting issue.
Hello guys!we have 5 XL Linux Media agents, and all of them have 2 DDB Partitions in the size of 5.9 TB. both of the DDB partitions are configured in RAID 1 when trying to configure storage pool from these media agents, we only can configure up to 6 DDB Partitons, and we need all 10 partitions to be available within the storage pool is there any chance of it?
I have a NDMP NAS SP (shares / subclients)I want to copy the data to a DR facility.My DASH copy is running very slow. 25GB/hr but the data to be copied is several TBs.Is there anything I can do to improve the performance?. How I can add more streams?
Hi all,I have a simple deployment with 2 Media Agent in GRID using SAN disk; deduplication is enabled on Media Agent.I wanted to segregate back-end storage for different platform (VMware, AIX, etc...) or customer. Is there any option to achieve that? Should I create many storage pool for each platform/client or is there any way to associate multiple libraries to the primary storage pool? Thank a lot for support.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.