Migrating Exchange Online Protection from EWS to Microsoft Graph: Post Your Questions Here
Ask questions. Find and share technical expertise, configuration tips, resilience best practices and more.
Recently active
Hello Commvault Community, While troubleshooting another topic, the Failover configuration was disabled and when I wanted to enable it again, I noticed something disturbing and I would like to ask whether this has changed in last versions or whether it is a bug that needs to be fixed.For clarity, I've checked this from both consoles (CommCell Console and CommandCenter), and both have the same problem.When we changed the CS Failover setting from "Existing Configuration" to "Use Network Gateway," changes were made to the Client Computer Groups and Network Topologies created by the CS Failover configuration. What concerned us was that nothing was displayed for the "External Clients for Failover" group and the "Proxy Clients for Failover" group. We repeatedly refreshed, restarted the console and tried the "Push Network Configuration" option, but nothing helped. Until we noticed that the Server Group/Client Computer Group association settings were set by default to search for clients/serve
Hi all, I would like to enable client-side deduplication on a Windows VSA proxy so that only unique data is sent directly from the VSA to the MediaAgent DDB/backup library, instead of sending all read data from the VSA and deduplicating only on the MediaAgent side.We are looking to this approach because the VSA proxy will be a VM inside an AVS environment, while the MediaAgent will be outside of AVS (as Azure VM). Could you please help with:Required packages on Windows VSA proxy: What Commvault packages are needed on the Windows server acting as VSA proxy to support client-side deduplication (e.g., Virtual Server, File System Core, File System, or any additional components)?How to enable client-side deduplication for VSA backups: What are the step-by-step configuration steps (storage policy, subclient properties, etc.) to enable source-side/client dedup specifically for VSA workloads?How to verify client-side dedup is working: What are the step-by-step checks (job details fields, repo
Considerations for Live Sync Configurations on combined CommServe & Media Agent deploymentHi All,I am planning a deployment of Commvault on a single physical server at a remote site which will require Live Sync to a secondary site.There are a couple of things that I am not sure about.If a failover is initiated how is the Media Agent component accessed as the services in Instance001 will be stopped. The same for the Media Agent component in Instance001 on the standby CS/MA.Is it an option to have the Media Agent installed into Instance002 on both Primary and Standby CommServe computers. Doing it this way would mean that the services will remain online.Then the Failover component will be deployed into Instance003?Is this a workable way or is there a different method that would be better?Thanks.Ignes
Team, Please assist me with latest commvault Stencils or templates
Dears,I have a vCenter environment, and I created a Red Hat 8 virtual machine to be used as a VSA proxy.I installed the Virtual Server package and the File System package successfully.However, after completing the installation, this node does not appear as an Access Node in the Virtualization configuration.Kindly advise why this is happening.Note: I am currently using a trial license.
Hello, We have renewed the support/maintenance contract for the CommCell via the Maintenance Advantage portal and received a new license XML file.Current license configuration:License type: Permanent Mode: Production Support/Maintenance: Expired ==> so we renewed this one for 1 year Question:Before applying the new license XML file :Will applying the new license file maintain the permanent license type, or will it change the license structure?The customer is concerned that applying the renewed support license might:Remove or modify the existing permanent license entitlements Convert from permanent to term/subscription licensing Impact production backupsMy expectation is this license file only update the support/maintenance expiration dateBut I need to prove it to the customer Can you help me pleaseThanks.Best regards,
We have decided to move our backup data to the NetApp AFF A90 and allow the existing NetApp system to age off in line with the retention policy.Could you please advise on how best to present the volumes to the MediaAgents—whether as block storage or via NFS? We would like to understand which option would be more suitable for our use case.Additionally, could you confirm whether NVMe is supported by Commvault version 11.40?
Hello, I am trying to reset secret key of end user but end user not getting nieuwe qr, i tested with trst user without MFA and i am getting e-mail to reset password.In webserver log i see that WEBAPI-STARTED processing [PUT]:[/User/Secret/Reset] request. : /User/Secret/Reset : AdditionalInfo[ ConsoleType[AdminConsole]]11336 91 04/16 13:07:25 91 e.skepko Invoke - WEBAPI-FINISHED processing [PUT]:[/CVWebService.svc/User/Secret/Reset] in [25] ms; HTTP code 'OK'
Hi all, I’m a bit confused about the "Snapshot options" section in the Server Plan settings, specifically when the plan is used for Microsoft 365 backups (Exchange, SharePoint, etc.). Since M365 backup is about mailboxes and sites, not VMs or LUNs, what is the actual purpose of this section? Does "Enable backup copy" or the snapshot schedule have any real effect on how M365 data is processed or moved to the storage? Or is this just a generic UI section for all Server Plans, or should I be aware of some specific logic here for M365 apps? Thanks for the clarification!
Hi,After migrating subclients from Index v1 to Index v2, VM backups within application clusters are losing time consistency on Selective Copies (e.g., First Full of the Month). The issue arises because Index v2 splits the subclient backup into individual child jobs for each VM; when these jobs finish after midnight, the system assigns them to different retention periods. Due to a fixed backup window, we cannot delay the start times, and manually selecting jobs for tape marks is not scalable.How to configure it so that Selective Copy treats all child jobs of a given subclient as a single time unit, ensuring a consistent point-in-time recovery for the entire application cluster? Kind regards,
Hi all. When I tried to do a full vm restore of a Nutanix VM with inPlaceRestore and overwriteVM set to True (tried from both command center UI and API), The expected behavior in my mind is that the vm’s metadata (vm description, categories, and UUID) is kept after the restore, just like how a VMware full vm restore has been working for us. In our testing, the vm is deleted and then re-created, causing the VM UUID to change, at the same time, all the other vm metadata fields like description and categories are not restored; Guest Tool connection is broken because of the new UUID as well. Is this expected behavior? Could this have been caused by misconfiguration on VM Group/Hypervisor side? Commvault 11.40Nutanix AHV 7.5 Thanks in advance!
Hi all, As I understand it, there are basically two possibilities regarding the Office 365 plan retention: Infinite and Retain deleted items for X period of time.Infinite: All items (e.g., emails, sites, folders) remain in the backups forever.Retain deleted items for X period: Only data that has been deleted from the source (M365) is removed from the backups after the given period. All other "live" (non-deleted) data remains in the backup forever, just like with the infinite option. Am I correct in thinking that once Office 365 data is backed up, it stays in the storage libraries forever, with the only exception being deleted data (when that option is selected)?Even though Server Plans have their own retention settings, do they affect Office 365 data? It seems to me that M365 data follows an "incremental forever" logic and there is no way for retention to delete "live" data from the storage.Please confirm my understanding or correct me if I am mistaken.Thanks in advance for your contri
Hi everyone,For about a week now, we have 2 failed mailboxes in the Exchange Online backups that have the failure reason "No valid Azure app found. Please run Check Readiness". In the same backups we have 346 mailboxes that show no issues.Only these 2 mailboxes have issues and I cannot find what is causing this. The mailboxes still exist and are no different from other shared mailboxes.The logs show no different errors for the mailboxes so I am a bit at a loss. I also see the same issue for multiple Exchange applications.Does anyone have an idea how to resolve this?Kind regards,Paul
I have deployed Commvault components using this procedure. But I’m not sure how to add my S3 Compatible storage SSL root certificate to be available on deployed pods.Please, can you tell me if there is a procedure in order to add the certificates on MediaAgent pods?Thanks
Hi Team, We are backing up a VM(hosted on MS HyperV) whose data disk is located on a SMB NAS File share.We are getting below error.Error Code: [91:300] Description: Error creating virtual machine [VMNAME] snapshot. Please check the virtual machine snapshot tree and the hosting volume for free space. [Checkpoint operation for 'VMNAME' failed. (Virtual machine ID 83A8CX27-…….A4) Checkpoint operation for 'VMNAME' was cancelled. (Virtual machine ID 83A8CX27-…….A4) 'VMNAME' could not initiate a checkpoint operation: The process cannot access the file because it is being used by another process. (0x80070020). (Virtual machine ID 83A8CX27-…….A4) 'VMNAME' could not create auto virtual hard disk \\IP\Host\VM_Disk_3714DCEE-3E97-4364-A678-897EF9FE93F0.avhdx: The process cannot access the file because it is being used by another process. (0x80070020). (Virtual machine ID 83A8CX27-…….A4)]. Source: commserve, Process: JobManager I have verified in the HyperV Host event viewer, it is throwing error “
Hi,i try to restore from a VM (guest files and folders) and i get this message: If i try to restore from a younger date it works fine.What can i do?ThanksDennis
Hi.Is there a supported way to manually upgrade Visual Studio Tools for Applications? I do not see any mention made of it.Current release is 16.0.31110Our customer advised that CVE-2025-29803 was detected in the current release. An upgrade should be done to version 16.0.35907.Current Commvault release is 11.40.42. I also don’t see any mention made in the Commvault maintenance release for this version. Any advise?Thanks.
Hi everyone,I'm working on a custom set of permissions for our MSSQL admins to allow them to perform on-demand backups. Despite granting what I believe to be more than sufficient privileges, they are still encountering errors.The process works perfectly when the user has master rights.Current permissions: Error with those: Has anyone successfully configured a least-privilege role for this scenario and could share?
Hello,After running a Synthetic Full Backup in our Commvault environment, the job completes successfully. However, we are unable to see any new Recovery Point in the CommCell Console / Command Center after the backup.ver: 11.40.38 Nis = April
Hi everyone, We are facing a confusing issue with the M365 Exchange Online agent in Commvault version 11.32.According to the documentation, under the Exchange connection settings:https://documentation.commvault.com/2023e/software/complete_microsoft_365_service_catalog_for_exchange_online_using_custom_configuration_option.html?_gl=1*hjd47t*_gcl_au*NjQ0NDk4ODY5LjE3Njk1OTU0OTI.I should click "Verify Connection" to validate the Azure app registration and update the app status. However, when I click this button, the status doesn't update to "Successful," and it remains blank or shows no confirmation of a successful binding.The strange part is that even though the verification seems to fail or does not show any status, I am able to browse through mailbox items and users within the Commvault Command Center in Office 365 app.Have you experienced this behavior before? Is it a known bug, or what is your take on this issue? Any input would be greatly appreciated!
Hi,After updating our environment to 11.40.42 I saw repeated log commit jobs failing with the following error.Sweep job has failed on Media Agent [XXXXXXXX]. Error [0xECCC000D:{I2::FileSweepScanner::Scan(684)} + {I2::SweepScanner::GenerateCollectFileForMountPath(269)} + {CQiFile::Open(95)} + {CQiUTFOSAPI::open(77)/ErrNo.13.(Permission denied)-Open failed, File=\\?\UNC\XX.XX.XX.XX\MountPoints\XXXXXXXX\Disk08\63WA3P_12.04.2024_11.32\CV_MAGNETIC\CV_APP_DUMPS\SDT\00DF80E8-D0C5-47B8-939E-E5BBC4908E99\collecttot2.cvf, OperationFlag=0x810A, PermissionMode=0x80}]I found that log caching was turned on at the plan that is used for the client. As we do not want to use log caching, I disabled the option on the t-log schedule in the plan.I now see that normal transaction log backups are running for the client instead of the log commit jobs. However, I still get a log commit job every 2 hours which keeps failing with this error.How do I get rid of the log commit job? A full backup has been made sinc
We are running a relatively new version of Ceph. In this newer Ceph release, the RBD commands used to create VM snapshots require specifying both the namespace and the keyring file to locate the VM disks. By contrast, Commvault locates VM disks using only the pool in its RBD command parameters. Commvault version 11.36 only supports older versions of Ceph.
Hi,I need to move the index directory on the index server node.Documentation and Arlie point to the workflow IndexServerDirectoryMove but this does not exist in the current environment and it is not available on the store.It is also not possible to manually change the directory location as the path in the edit node screen is greyed out.I hope anyone can help me with this issue.
Hello,we have a problem to configure a RAC instance where the database name is longer than 8 letters. When we try to configure it, we see in the logs that the database names is shorten to 8 letters:The database name is AKJFP14LOG [B,2555900358,AKJFP14L,ARCHIVELOG,READ WRITE,12776703,I,1,akjfp14log,server1, NO, 1,] size=[0]28841 70a9 05/03 13:05:24 ### RacBrowser::LocalInstanceBrowse() - Oracle SbtLibrary:[/opt/commvault/Base/libobk.so]28841 70a9 05/03 13:05:24 ### RacBrowser::FillInstanceStatus(1034) - m_oraInfoReturn [B,2555900358,AKJFP14L,ARCHIVELOG,READ WRITE,12776703,I,1,akjfp14log,server1, NO, 1,] size=[0]28841 70a9 05/03 13:05:24 ### RacBrowser::ValidateDBProps() - Received DBStatus=READ WRITEIs it a problem with /opt/commvault/Base/libobk.so?Thank you.Thomas
I dont have work mail id as i lost my job and i want to take up CV Certification with my Personal mail? how to register for exam?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.